summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-03-28 14:15:10 +1300
committerKent Fredric <kentnl@gentoo.org>2018-03-28 14:16:06 +1300
commit176344a770952235f2229bbd28a8078cbb9c3393 (patch)
treec221bcc7706ce7a4f548a92cbf9a581c25b206f3 /dev-perl/XML-Simple
parentsys-auth/sssd-1.13.1: added ~mips, bug 540540 (diff)
downloadgentoo-176344a770952235f2229bbd28a8078cbb9c3393.tar.gz
gentoo-176344a770952235f2229bbd28a8078cbb9c3393.tar.bz2
gentoo-176344a770952235f2229bbd28a8078cbb9c3393.zip
dev-perl/XML-Simple: Bump to version 2.250.0
- Fix tests failing with XML::LibXML::SAX ( #625538 ) - Purge author tests Upstream: - Improve circular reference detection - Don't initialise PREFERRED_PARSER to undef during load - Disable entity expansion when using XML::Parser - Call to XML::Parser constructor now in isolated method for subclass overriding Bug: https://bugs.gentoo.org/625538 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-perl/XML-Simple')
-rw-r--r--dev-perl/XML-Simple/Manifest1
-rw-r--r--dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild27
-rw-r--r--dev-perl/XML-Simple/files/XML-Simple-2.25-saxtests.patch45
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-perl/XML-Simple/Manifest b/dev-perl/XML-Simple/Manifest
index 0f2dcc6279f5..33fe2b614f4e 100644
--- a/dev-perl/XML-Simple/Manifest
+++ b/dev-perl/XML-Simple/Manifest
@@ -1,2 +1,3 @@
DIST XML-Simple-2.20.tar.gz 75993 BLAKE2B 59edf0397247ff25f940c470263c87f7b49bae1806395b52a2399a3caca9d54485b9fb84c45065d4066315404722608bb176918a0f8e628108d903128d4d8294 SHA512 f953a0b9082c509c4616b92529da94a289b1e0300b18a5b88c08d0826bb4fd18e51f1e3854e6f870ef3cfb506366c0b47b9dd302433b63270a18b45f068d4658
DIST XML-Simple-2.22.tar.gz 77937 BLAKE2B aaaaccc9035584f468767e7408718e76821012173cefda53eb8b8cc7280ef11794c3443367ef1a2b1d84b98eeefc15394a7b231f856e3a2a412e094d20bb81a8 SHA512 b5e5d36726b8a0efcf7200522d802a7f733c883526db2dba64ce23bf7e044d20d9186fac3bb2f2940807a30f746301f690129c4c542341c8a57a735471b5f4d7
+DIST XML-Simple-2.25.tar.gz 78443 BLAKE2B 6b990c0095fd573ce92db8ca4fbeaf259b33817992bbc0f465dcf1df1f77b56d5229b94a062a59178676500f7445ddf824a8e0d05b21df9ce1a5491d328eee48 SHA512 0f1a6a1bdb8f6ac6fa4deef33d09930eb4758b4a3ed4431624004ffa2b1eb02f0d6ce14cb4942162cb76f7aa39fea4ec6a71e1eb9ebd464b710db7024bdd990c
diff --git a/dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild b/dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild
new file mode 100644
index 000000000000..44f22539e97c
--- /dev/null
+++ b/dev-perl/XML-Simple/XML-Simple-2.250.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=GRANTM
+DIST_VERSION=2.25
+inherit perl-module
+
+DESCRIPTION="An API for simple XML files"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Storable
+ >=dev-perl/XML-NamespaceSupport-1.40.0
+ >=dev-perl/XML-SAX-0.150.0
+ dev-perl/XML-SAX-Expat
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.880.0 )
+"
+PATCHES=("${FILESDIR}/${PN}-2.25-saxtests.patch")
+PERL_RM_FILES=("t/author-pod-syntax.t")
diff --git a/dev-perl/XML-Simple/files/XML-Simple-2.25-saxtests.patch b/dev-perl/XML-Simple/files/XML-Simple-2.25-saxtests.patch
new file mode 100644
index 000000000000..58739b7e4902
--- /dev/null
+++ b/dev-perl/XML-Simple/files/XML-Simple-2.25-saxtests.patch
@@ -0,0 +1,45 @@
+From 83774c87a0cc98379bc166fc0f6d028e68063a53 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Tue, 27 Mar 2018 20:11:48 +1300
+Subject: Force XML::SAX::PurePerl for XMLin/XMLout tests
+
+As for some reason, accidentally getting XML::LibXML::SAX
+results in this test failing with encoding problems.
+
+Bug: https://bugs.gentoo.org/625538
+---
+ t/1_XMLin.t | 3 +++
+ t/2_XMLout.t | 2 ++
+ 2 files changed, 5 insertions(+)
+
+diff --git a/t/1_XMLin.t b/t/1_XMLin.t
+index 84935cd..bd5cf71 100644
+--- a/t/1_XMLin.t
++++ b/t/1_XMLin.t
+@@ -6,6 +6,9 @@ use IO::File;
+ use File::Spec;
+
+ use XML::Simple;
++use XML::SAX;
++
++$XML::SAX::ParserPackage = "XML::SAX::PurePerl";
+
+ # Initialise filenames and check they're there
+
+diff --git a/t/2_XMLout.t b/t/2_XMLout.t
+index 471d9ce..d0d8dcf 100644
+--- a/t/2_XMLout.t
++++ b/t/2_XMLout.t
+@@ -26,7 +26,9 @@ sub ReadFile {
+ }
+
+ use XML::Simple;
++use XML::SAX;
+
++$XML::SAX::ParserPackage = "XML::SAX::PurePerl";
+ # Confirm error when mandatory parameter missing
+
+ $_ = eval {
+--
+2.16.2
+