summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-11 16:28:51 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-11 22:14:17 +0200
commit8848e2c0269642a3675f58d5b3045cb754281975 (patch)
tree36279a71d879e967451e91aa5d9966dfa4c61b15 /dev-perl/gtk2-gladexml/gtk2-gladexml-1.8.0.ebuild
parentdev-perl/gtk2-ex-formfactory: EAPI=8 bump (diff)
downloadgentoo-8848e2c0269642a3675f58d5b3045cb754281975.tar.gz
gentoo-8848e2c0269642a3675f58d5b3045cb754281975.tar.bz2
gentoo-8848e2c0269642a3675f58d5b3045cb754281975.zip
dev-perl/gtk2-gladexml: Version bump 1.008
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/gtk2-gladexml/gtk2-gladexml-1.8.0.ebuild')
-rw-r--r--dev-perl/gtk2-gladexml/gtk2-gladexml-1.8.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/gtk2-gladexml/gtk2-gladexml-1.8.0.ebuild b/dev-perl/gtk2-gladexml/gtk2-gladexml-1.8.0.ebuild
new file mode 100644
index 000000000000..30133c486870
--- /dev/null
+++ b/dev-perl/gtk2-gladexml/gtk2-gladexml-1.8.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_NAME=Gtk2-GladeXML
+DIST_AUTHOR=XAOC
+DIST_VERSION=1.008
+DIST_EXAMPLES=("examples/*")
+inherit perl-module virtualx
+
+DESCRIPTION="Create user interfaces directly from Glade XML files"
+HOMEPAGE="http://gtk2-perl.sf.net/ https://metacpan.org/release/Gtk2-GladeXML"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc64 ~x86"
+
+RDEPEND="x11-libs/gtk+:2
+ gnome-base/libglade:2.0
+ >=dev-perl/glib-perl-1.020
+ >=dev-perl/Gtk2-1.012"
+BDEPEND="${RDEPEND}
+ >=dev-perl/ExtUtils-Depends-0.300
+ dev-perl/ExtUtils-PkgConfig"
+
+src_test() {
+ virtx perl-module_src_test
+}