summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-06-01 00:14:45 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-06-01 00:15:40 +0200
commitee9a5d36267bc6211d2a2ffa76440ec252bbbfec (patch)
tree18a8ae43efbb7d9af4a96a54f04e3fc70d5fad1f /dev-perl/libintl-perl/files
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-ee9a5d36267bc6211d2a2ffa76440ec252bbbfec.tar.gz
gentoo-ee9a5d36267bc6211d2a2ffa76440ec252bbbfec.tar.bz2
gentoo-ee9a5d36267bc6211d2a2ffa76440ec252bbbfec.zip
dev-perl/libintl-perl: More minimal patching, fixes bug 584636
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-perl/libintl-perl/files')
-rw-r--r--dev-perl/libintl-perl/files/libintl-perl-1.240.0-sanity-2.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/libintl-perl/files/libintl-perl-1.240.0-sanity-2.patch b/dev-perl/libintl-perl/files/libintl-perl-1.240.0-sanity-2.patch
new file mode 100644
index 000000000000..e6adbf1419b8
--- /dev/null
+++ b/dev-perl/libintl-perl/files/libintl-perl-1.240.0-sanity-2.patch
@@ -0,0 +1,51 @@
+diff -ruN libintl-perl-1.24.orig/Makefile.PL libintl-perl-1.24/Makefile.PL
+--- libintl-perl-1.24.orig/Makefile.PL 2015-04-03 15:28:12.000000000 +0200
++++ libintl-perl-1.24/Makefile.PL 2016-06-01 00:06:12.000000000 +0200
+@@ -163,47 +163,6 @@
+
+ package MY;
+
+-# FIXME: This is really a hack! Problem: Depending on the build system,
+-# we may or may not build and install the XS version. If the XS version
+-# is being built, the directory blib/arch will be populated, if it is
+-# not being built, blib/arch will be empty. Unfortunately, if blib/arch
+-# is not empty, *all* library files will be installed in the architecture
+-# dependent locations, if it is empty, they will be installed in the
+-# architecture independent tree.
+-#
+-# Unfortunately, ExtUtils::MakeMaker does not take care of uninstalling
+-# files from previous installations. Consequently, we cannot determine
+-# which version of the library will be loaded, since this depends on the
+-# current value of @INC.
+-#
+-# The solution does not really make me happy. The Makefile will be patched,
+-# so that instead of ExtUtils::Install a custom module MyInstall.pm will
+-# be used. This custom module overwrites the subroutine that detects
+-# whether a directory is empty in ExtUtils::Install, and will lie if that
+-# directory happens to be "blib/arch". This little hack effectively disables
+-# the annoying behavior of ExtUtils::Install (and I sincerely hope that
+-# this is portable).
+-sub libscan
+-{
+- my ($self, $file) = @_;
+-
+- return if 'MyInstall.pm' eq $file;
+-
+- $self->SUPER::libscan ($file);
+-}
+-
+-sub tools_other
+-{
+- my $self = shift;
+-
+- my $fragment = $self->SUPER::tools_other (@_);
+-
+- $fragment =~ s/^MOD_INSTALL\s*=\s*(.*?)-MExtUtils::Install
+- /MOD_INSTALL =$1-MMyInstall/msx;
+-
+- return $fragment;
+-}
+-
+ package main;
+
+ my $name = $0;