summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-02 15:22:32 +0000
committerSam James <sam@gentoo.org>2022-07-02 15:32:10 +0000
commitac9cbefb1c536bb187a148605d7864b28a6a0ea5 (patch)
tree8340a266caae9eaf4d79526403e7d86cb3b2a46d /dev-perl/librg-utils-perl
parentnet-dns/dnsviz: drop 0.8.2-r1, 0.9.2, 0.9.3 (diff)
downloadgentoo-ac9cbefb1c536bb187a148605d7864b28a6a0ea5.tar.gz
gentoo-ac9cbefb1c536bb187a148605d7864b28a6a0ea5.tar.bz2
gentoo-ac9cbefb1c536bb187a148605d7864b28a6a0ea5.zip
dev-perl/librg-utils-perl: update EAPI 6 -> 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/librg-utils-perl')
-rw-r--r--dev-perl/librg-utils-perl/librg-utils-perl-1.0.43-r2.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-perl/librg-utils-perl/librg-utils-perl-1.0.43-r2.ebuild b/dev-perl/librg-utils-perl/librg-utils-perl-1.0.43-r2.ebuild
new file mode 100644
index 000000000000..b61dd58c9a08
--- /dev/null
+++ b/dev-perl/librg-utils-perl/librg-utils-perl-1.0.43-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Parsers and format conversion utilities used by (e.g.) profphd"
+HOMEPAGE="http://rostlab.org/"
+SRC_URI="ftp://rostlab.org/librg-utils-perl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-perl/List-MoreUtils"
+DEPEND="${RDEPEND}
+ sci-libs/profphd-utils"
+BDEPEND="dev-perl/Module-Build"
+
+PATCHES=(
+ "${FILESDIR}/${P}-defined-array.patch"
+)
+
+src_configure() {
+ econf
+ perl-module_src_configure
+}
+
+src_test() {
+ local MODULES=(
+ "RG::Utils::Conv_hssp2saf"
+ "RG::Utils::Hssp_filter"
+ "RG::Utils::Copf"
+ )
+ local failed=()
+
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+
+ if [[ ${failed[@]} ]]; then
+ eerror "One or more modules failed compile:"
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors"
+ fi
+
+ perl-module_src_test
+}
+
+src_install() {
+ rm mat/Makefile* || die
+
+ perl-module_src_install
+
+ insinto /usr/share/${PN}
+ doins -r mat
+
+ exeinto /usr/share/${PN}
+ doexe *.pl dbSwiss
+
+ doman blib/libdoc/*
+}