summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-20 02:26:28 +0000
committerSam James <sam@gentoo.org>2021-12-20 04:08:32 +0000
commit4252a77eea7d71341f594bd899b76ea2d984e68c (patch)
treea60b2559eecece3a36ba6ebd52659dca84497d4c /dev-perl/libwww-perl
parentsys-devel/mold: use system xxhash in 9999 (diff)
downloadgentoo-4252a77eea7d71341f594bd899b76ea2d984e68c.tar.gz
gentoo-4252a77eea7d71341f594bd899b76ea2d984e68c.tar.bz2
gentoo-4252a77eea7d71341f594bd899b76ea2d984e68c.zip
dev-perl/libwww-perl: add 6.600.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/libwww-perl')
-rw-r--r--dev-perl/libwww-perl/Manifest1
-rw-r--r--dev-perl/libwww-perl/libwww-perl-6.600.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-perl/libwww-perl/Manifest b/dev-perl/libwww-perl/Manifest
index 8d5dbd808825..47720140c82e 100644
--- a/dev-perl/libwww-perl/Manifest
+++ b/dev-perl/libwww-perl/Manifest
@@ -1 +1,2 @@
DIST libwww-perl-6.55.tar.gz 177842 BLAKE2B 5952f311024357f8601e0e5583ae4cf9e18167aefc20a9901a090df7dd0b7f61266784fe3ca3a64d317cb089b0f8aa61e5fce61727ba7b43eaec555d131c98d2 SHA512 4a26bbcea343af513cc7d22761b7b9412da864bc7ff5e6d8cc6494978ceb829f001d1e221482a215e363e7f7857002120dbd12fda14b1b5778b1f437a5e338eb
+DIST libwww-perl-6.60.tar.gz 179043 BLAKE2B e6a5f4186b8f7ef707c7150bac734572948b14fb6200920ba7acee1ab4b31bdaa6856bcbd1a50622c73cd5a1482792b0447513107f8f60d4d585d448a81cf4c4 SHA512 9f7e45c9beb36a2147b81ee16a86ecf99da79485df6198d2439325d1cc0f186d5b27b46d39a4583e54fddd4cbdd87f455190b57f11065a03db1bacfb61506544
diff --git a/dev-perl/libwww-perl/libwww-perl-6.600.0.ebuild b/dev-perl/libwww-perl/libwww-perl-6.600.0.ebuild
new file mode 100644
index 000000000000..703519c8526d
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-6.600.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=OALDERS
+DIST_VERSION=6.60
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="ssl"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ >=virtual/perl-Encode-2.120.0
+ dev-perl/Encode-Locale
+ >=dev-perl/File-Listing-6.0.0
+ >=dev-perl/HTML-Parser-3.340.0
+ >=dev-perl/HTTP-Cookies-6.0.0
+ >=dev-perl/HTTP-Date-6.0.0
+ >=dev-perl/HTTP-Negotiate-6.0.0
+ >=dev-perl/HTTP-Message-6.70.0
+ virtual/perl-IO
+ >=dev-perl/LWP-MediaTypes-6.0.0
+ >=virtual/perl-MIME-Base64-2.100.0
+ >=virtual/perl-libnet-2.580.0
+ >=dev-perl/Net-HTTP-6.180.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ >=dev-perl/URI-1.100.0
+ >=dev-perl/WWW-RobotRules-6.0.0
+ >=virtual/perl-parent-0.217.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-CPAN-Meta-Requirements-2.120.620
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Getopt-Long
+ virtual/perl-Module-Metadata
+ test? (
+ virtual/perl-File-Spec
+ >=dev-perl/HTTP-Daemon-6.120.0
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/Test-Needs
+ dev-perl/Test-RequiresInternet
+ )
+"
+PDEPEND="
+ ssl? (
+ >=dev-perl/LWP-Protocol-https-6.20.0
+ )
+"
+
+src_install() {
+ perl-module_src_install
+
+ # Perform a check to see if the live filesystem is case-INsensitive
+ # or not. If it is, the symlinks GET, POST and in particular HEAD
+ # will collide with e.g. head from coreutils. While under Linux
+ # having a case-INsensitive filesystem is really unusual, most Mac
+ # OS X users are on it, and also Interix users deal with
+ # case-INsensitivity since Windows is underneath.
+
+ # bash should always be there, if we can find it in capitals, we're
+ # on a case-INsensitive filesystem.
+ if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
+ dosym lwp-request /usr/bin/GET
+ dosym lwp-request /usr/bin/POST
+ dosym lwp-request /usr/bin/HEAD
+ fi
+}