summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-05 22:45:55 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-05 22:46:32 +1300
commit2923a103c1c67e46afc562d95a8de734f81728d3 (patch)
tree9f51edc17766f86e162f3cac54a45eaadbaac08c /dev-perl
parentdev-perl/JSON-Parse: Added at version 0.420.0 (diff)
downloadgentoo-2923a103c1c67e46afc562d95a8de734f81728d3.tar.gz
gentoo-2923a103c1c67e46afc562d95a8de734f81728d3.tar.bz2
gentoo-2923a103c1c67e46afc562d95a8de734f81728d3.zip
dev-perl/Google-Ads-AdWords-Client: Bump to version 4.11.0
- EAPI6 - Add USE=examples - Restore tests (working) - Upstream -> CPAN instead of GoogleCode - Deps cleaned up Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-4.11.0.ebuild52
-rw-r--r--dev-perl/Google-Ads-AdWords-Client/Manifest1
-rw-r--r--dev-perl/Google-Ads-AdWords-Client/metadata.xml47
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-4.11.0.ebuild b/dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-4.11.0.ebuild
new file mode 100644
index 000000000000..6dba24c90b1a
--- /dev/null
+++ b/dev-perl/Google-Ads-AdWords-Client/Google-Ads-AdWords-Client-4.11.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+DIST_AUTHOR=SUNDQUIST
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Google AdWords API Perl Client Library"
+HOMEPAGE="https://github.com/googleads/googleads-perl-lib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Class-Load
+ >=dev-perl/Class-Std-Fast-0.0.5
+ dev-perl/Crypt-OpenSSL-RSA
+ dev-perl/File-HomeDir
+ virtual/perl-File-Spec
+ dev-perl/IO-Socket-SSL
+ dev-perl/JSON-Parse
+ dev-perl/LWP-Protocol-https
+ dev-perl/libwww-perl
+ dev-perl/Log-Log4perl
+ >=dev-perl/SOAP-WSDL-2.00.10
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Template-Toolkit
+ dev-perl/URI
+ dev-perl/XML-Simple
+ dev-perl/XML-XPath
+ examples? (
+ virtual/perl-Digest-SHA
+ virtual/perl-File-Temp
+ dev-perl/HTTP-Server-Simple
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.400.0
+ test? (
+ dev-perl/Config-Properties
+ dev-perl/Data-Uniqid
+ virtual/perl-File-Temp
+ dev-perl/Test-Deep
+ dev-perl/Test-Exception
+ dev-perl/Test-MockObject
+ virtual/perl-Test-Simple
+ )
+"
diff --git a/dev-perl/Google-Ads-AdWords-Client/Manifest b/dev-perl/Google-Ads-AdWords-Client/Manifest
index 5589c6db50b0..196a0910c54a 100644
--- a/dev-perl/Google-Ads-AdWords-Client/Manifest
+++ b/dev-perl/Google-Ads-AdWords-Client/Manifest
@@ -1 +1,2 @@
+DIST Google-Ads-AdWords-Client-4.11.0.tar.gz 4863360 SHA256 5117987ac8600e0c70342bfb8ed3ac355b4b79af3d30ee27e39ed438fba992ac SHA512 c4209469889d6359779f8153684e5c93d9db837b27c8de6fb96384def3a0dcd7b4815c5a37f21041f0a052d1273e3a2ea9b76f5f15071e9ee3c96f89e19cda3a WHIRLPOOL ec68c41c2b24d26373aeb776cf28e11804b7afc08f8c61fd6d8f6a1376061922a86fbcb2d74650510e1a81a086d812d0114609550fed5ad128ec1255b757224f
DIST awapi_perl_lib_2_7_3.tar.gz 8657336 SHA256 4016b94ee7b646e0adf97e21846a09f0125467c7c167cfdb9f1581a5d38c3eb4 SHA512 9181f3944844e86f208d6127b1c63cea250eddfdc68a9a30978e488fb166b2e3ef4c67a1b86c768d8fd910b847b51da77c8748abd6f73670434590474398fb1a WHIRLPOOL 5fe639949828825aa70c34e0072ff5850aef4f1bfc12f4c553126c424b288a7b3b62953586c50405fcb99086b01e8a448e9502af926b5820ad5e618ea58f9126
diff --git a/dev-perl/Google-Ads-AdWords-Client/metadata.xml b/dev-perl/Google-Ads-AdWords-Client/metadata.xml
index d1a9bbb2fd1d..d1774500bbac 100644
--- a/dev-perl/Google-Ads-AdWords-Client/metadata.xml
+++ b/dev-perl/Google-Ads-AdWords-Client/metadata.xml
@@ -7,5 +7,52 @@
</maintainer>
<upstream>
<remote-id type="github">googleads/googleads-perl-lib</remote-id>
+ <remote-id type="cpan">Google-Ads-AdWords-Client</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Client</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Constants</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Deserializer</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::FaultDetail</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Logging</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::OAuth2ApplicationsHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::OAuth2ServiceAccountsHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::DateRange</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::DateRangeType</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::DownloadFormat</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::Operator</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::OrderBy</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::Paging</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::Predicate</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::ReportDefinition</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::ReportType</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::ReportingConfiguration</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::Selector</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Reports::SortOrder</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::RequestStats</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Serializer</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Utilities::BatchJobHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Utilities::BatchJobHandlerError</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Utilities::BatchJobHandlerStatus</remote-id>
+ <remote-id type="cpan-module">Google::Ads::AdWords::Utilities::PageProcessor</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::AuthError</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::AuthHandlerInterface</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::CaptchaRequiredError</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::Constants</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::ErrorUtils</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::HTTPTransport</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::MapUtils</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::MediaUtils</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::OAuth2ApplicationsHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::OAuth2BaseHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::OAuth2ServiceAccountsHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::OAuthApplicationsHandlerInterface</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::ReportDownloadError</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::ReportDownloadHandler</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::ReportUtils</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::Utilities::AdsUtilityRegistry</remote-id>
+ <remote-id type="cpan-module">Google::Ads::Common::XPathSAXParser</remote-id>
+ <remote-id type="cpan-module">Google::Ads::SOAP::Deserializer::MessageParser</remote-id>
+ <remote-id type="cpan-module">Google::Ads::SOAP::Generator::Generator</remote-id>
+ <remote-id type="cpan-module">Google::Ads::SOAP::Generator::TypemapVisitor</remote-id>
+ <remote-id type="cpan-module">Google::Ads::SOAP::Typelib::ComplexType</remote-id>
</upstream>
</pkgmetadata>