summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-26 06:46:15 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-26 06:46:35 +1200
commit478cbb8a1bbd51b99d47d56dbc8631013b72b572 (patch)
tree13e4affe58993b3224fba1c4838a2bbb1e6940f0 /dev-perl
parentdev-db/percona-server: update known test failures (diff)
downloadgentoo-478cbb8a1bbd51b99d47d56dbc8631013b72b572.tar.gz
gentoo-478cbb8a1bbd51b99d47d56dbc8631013b72b572.tar.bz2
gentoo-478cbb8a1bbd51b99d47d56dbc8631013b72b572.zip
dev-perl/DateTime-Format-HTTP: -r bump for EAPI7
- EAPI7 - Patch bad tests unconditionally - Parallel tests Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/DateTime-Format-HTTP/DateTime-Format-HTTP-0.420.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-HTTP/DateTime-Format-HTTP-0.420.0-r1.ebuild b/dev-perl/DateTime-Format-HTTP/DateTime-Format-HTTP-0.420.0-r1.ebuild
new file mode 100644
index 000000000000..6722e142579e
--- /dev/null
+++ b/dev-perl/DateTime-Format-HTTP/DateTime-Format-HTTP-0.420.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=CKRAS
+DIST_VERSION=0.42
+inherit perl-module
+
+DESCRIPTION="Date conversion routines"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/DateTime-0.170.0
+ >=dev-perl/HTTP-Date-1.440.0
+"
+DEPEND="dev-perl/Module-Build"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.380.0
+ test? ( >=virtual/perl-Test-Simple-0.470.0 )
+"
+PERL_RM_FILES=(
+ t/pod.t
+ t/pod-coverage.t
+)