summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-22 18:34:20 +0100
committerSam James <sam@gentoo.org>2022-04-22 18:36:03 +0100
commit48de9776962bd33009885e7a71da5a9a8b67c7dc (patch)
tree7e06335ce9e8797bb21cb987a8086611bd07897c /dev-perl
parentdev-perl/XML-SAX: fix ROOT check in pkg_postinst (diff)
downloadgentoo-48de9776962bd33009885e7a71da5a9a8b67c7dc.tar.gz
gentoo-48de9776962bd33009885e7a71da5a9a8b67c7dc.tar.bz2
gentoo-48de9776962bd33009885e7a71da5a9a8b67c7dc.zip
dev-perl/XML-LibXML: fix ROOT check in pkg_postinst
Bug: https://bugs.gentoo.org/840053 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-2.20.700-r1.ebuild (renamed from dev-perl/XML-LibXML/XML-LibXML-2.20.700.ebuild)4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-perl/XML-LibXML/XML-LibXML-2.20.700.ebuild b/dev-perl/XML-LibXML/XML-LibXML-2.20.700-r1.ebuild
index ebe51ebbecf4..ef2735eef3b7 100644
--- a/dev-perl/XML-LibXML/XML-LibXML-2.20.700.ebuild
+++ b/dev-perl/XML-LibXML/XML-LibXML-2.20.700-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -65,7 +65,7 @@ pkg_update_parser() {
local action=$1
local parser_module=$2
- if [[ "$ROOT" = "/" ]] ; then
+ if [[ -z "${ROOT}" ]] ; then
einfo "Update Parser: $1 $2"
perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
|| ewarn "Update Parser: $1 $2 failed"