summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-16 22:07:29 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-16 22:07:29 +0200
commit53aa4895ddbf4320f5a76c3de8a085e6a3a3e669 (patch)
tree075166772a8252531b249bdc984af57a4ae89484 /dev-perl
parentdev-perl/Net-Netmask: Remove old (diff)
downloadgentoo-53aa4895ddbf4320f5a76c3de8a085e6a3a3e669.tar.gz
gentoo-53aa4895ddbf4320f5a76c3de8a085e6a3a3e669.tar.bz2
gentoo-53aa4895ddbf4320f5a76c3de8a085e6a3a3e669.zip
dev-perl/Data-Password-passwdqc: Simplify; EAPI=8
Closes: https://bugs.gentoo.org/815895 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Data-Password-passwdqc/Data-Password-passwdqc-0.90.0-r1.ebuild (renamed from dev-perl/Data-Password-passwdqc/Data-Password-passwdqc-0.90.0.ebuild)17
1 files changed, 5 insertions, 12 deletions
diff --git a/dev-perl/Data-Password-passwdqc/Data-Password-passwdqc-0.90.0.ebuild b/dev-perl/Data-Password-passwdqc/Data-Password-passwdqc-0.90.0-r1.ebuild
index 48b88d3924e8..bdc294294215 100644
--- a/dev-perl/Data-Password-passwdqc/Data-Password-passwdqc-0.90.0.ebuild
+++ b/dev-perl/Data-Password-passwdqc/Data-Password-passwdqc-0.90.0-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DIST_AUTHOR=SHERWIN
DIST_VERSION=0.09
@@ -10,8 +10,6 @@ inherit perl-module
DESCRIPTION="Check password strength and generate password using passwdqc"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
virtual/perl-Carp
@@ -26,23 +24,18 @@ BDEPEND="${RDEPEND}
virtual/perl-Test-Simple
)
"
+
PERL_RM_FILES=(
t/pod.t
)
+
src_prepare() {
- ebegin "Stripping Devel-CheckOS from inc/"
+ einfo "Stripping Devel-CheckOS from inc/"
rm -rf "${S}/inc/Devel/CheckOS.pm" \
"${S}/inc/Devel/AssertOS.pm" \
"${S}/inc/Devel/AssertOS" ||
die "Can't remove bundled Devel-CheckOS bits"
sed -i -e '/^inc\/Devel\/\(Check\|Assert\)OS/d' MANIFEST ||
die "Can't remove Devel-CheckOS bits from MANIFEST"
- eend
perl-module_src_prepare
}
-src_compile() {
- mymake=(
- "OPTIMIZE=${CFLAGS}"
- )
- perl-module_src_compile
-}