summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2021-08-03 21:36:04 +0200
committerPatrice Clement <monsieurp@gentoo.org>2021-08-03 21:36:14 +0200
commit5a1d69f2e3d9015a0441d737cbcd4ad32855918a (patch)
tree9d22f7324bf64e96aa68f7f610ba1ea2084c58f0 /dev-perl
parentdev-perl/Gentoo-App-Pram: reword DESCRIPTION. (diff)
downloadgentoo-5a1d69f2e3d9015a0441d737cbcd4ad32855918a.tar.gz
gentoo-5a1d69f2e3d9015a0441d737cbcd4ad32855918a.tar.bz2
gentoo-5a1d69f2e3d9015a0441d737cbcd4ad32855918a.zip
dev-perl/Gentoo-App-Pram: EAPI v8 bump.
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild b/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild
new file mode 100644
index 000000000000..5d83f1ee0e10
--- /dev/null
+++ b/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MONSIEURP
+DIST_VERSION=0.200000
+
+inherit perl-module
+
+DESCRIPTION="Tool to merge PRs from the Gentoo Github repository"
+HOMEPAGE="https://github.com/monsieurp/Gentoo-App-Pram"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-vcs/git
+ virtual/perl-Encode
+ dev-perl/File-Which
+ dev-perl/Net-SSLeay
+ dev-perl/IO-Socket-SSL
+ virtual/perl-File-Temp
+ virtual/perl-HTTP-Tiny
+ virtual/perl-Getopt-Long
+ virtual/perl-Term-ANSIColor
+ !app-portage/pram"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ )"
+
+BDEPEND="
+ ${RDEPEND}
+ dev-perl/Module-Build-Tiny"