summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-10 22:33:12 +0000
committerSam James <sam@gentoo.org>2022-03-10 22:33:12 +0000
commitb1fbfa633e03ebcfb90a1a84781e5b6eeab64338 (patch)
tree740281ec88e5d3f19410452b52a40676694b4a34 /dev-perl
parentmedia-gfx/hydrus: Drop 469, add 476, update 9999 (diff)
downloadgentoo-b1fbfa633e03ebcfb90a1a84781e5b6eeab64338.tar.gz
gentoo-b1fbfa633e03ebcfb90a1a84781e5b6eeab64338.tar.bz2
gentoo-b1fbfa633e03ebcfb90a1a84781e5b6eeab64338.zip
dev-perl/Search-Xapian: don't call tc-getCXX in global scope
Closes: https://bugs.gentoo.org/593366 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.25.0.ebuild7
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.25.4-r1.ebuild7
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r1.ebuild5
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.25.5.ebuild5
4 files changed, 18 insertions, 6 deletions
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.0.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.0.ebuild
index b8cfbc7060ef..5cc9b91c2ae4 100644
--- a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.0.ebuild
+++ b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -27,7 +27,10 @@ DEPEND="${RDEPEND}
DIST_TEST=do
# parallel fails sometimes...
-myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+src_configure() {
+ myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+ perl-module_src_configure
+}
src_install() {
perl-module_src_install
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.4-r1.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.4-r1.ebuild
index 3a61a1ff3b12..f7d7e72802ad 100644
--- a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.4-r1.ebuild
+++ b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,7 +26,10 @@ DEPEND="${RDEPEND}
DIST_TEST=do
# parallel fails sometimes...
-myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+src_configure() {
+ myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+ perl-module_src_configure
+}
src_install() {
perl-module_src_install
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r1.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r1.ebuild
index b3fef4008d7b..9e0f99acb617 100644
--- a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r1.ebuild
+++ b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r1.ebuild
@@ -23,7 +23,10 @@ DEPEND="${RDEPEND}
DIST_TEST=do
# parallel fails sometimes...
-myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+src_configure() {
+ myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+ perl-module_src_configure
+}
src_install() {
perl-module_src_install
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5.ebuild
index e7e3101f4ac3..0c320bfdd619 100644
--- a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5.ebuild
+++ b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5.ebuild
@@ -26,7 +26,10 @@ DEPEND="${RDEPEND}
DIST_TEST=do
# parallel fails sometimes...
-myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+src_configure() {
+ myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+ perl-module_src_configure
+}
src_install() {
perl-module_src_install