summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-09-20 16:46:44 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-09-20 18:38:00 +0200
commitc7b3f939dd640413a2676a14387d67cd812ed65b (patch)
tree9c8949d873fe516607f9b2fa9a4848a020f7b8ff /dev-perl
parentdev-perl/Crypt-SMIME: add libressl support (diff)
downloadgentoo-c7b3f939dd640413a2676a14387d67cd812ed65b.tar.gz
gentoo-c7b3f939dd640413a2676a14387d67cd812ed65b.tar.bz2
gentoo-c7b3f939dd640413a2676a14387d67cd812ed65b.zip
dev-perl/Crypt-SSLeay: add libressl support
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r1.ebuild b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r1.ebuild
new file mode 100644
index 000000000000..105138eee699
--- /dev/null
+++ b/dev-perl/Crypt-SSLeay/Crypt-SSLeay-0.720.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=NANIS
+MODULE_VERSION=0.72
+inherit perl-module
+
+DESCRIPTION="OpenSSL support for LWP"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libressl test"
+
+RDEPEND="
+ !libressl? ( >=dev-libs/openssl-0.9.7c:0 )
+ libressl? ( dev-libs/libressl )
+ virtual/perl-MIME-Base64
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=virtual/perl-ExtUtils-CBuilder-0.280.205
+ virtual/perl-Getopt-Long
+ >=dev-perl/Path-Class-0.260.0
+ >=dev-perl/Try-Tiny-0.190.0
+ test? (
+ >=virtual/perl-Test-Simple-0.190.0
+ )
+"
+# PDEPEND: circular dependencies bug #144761
+PDEPEND="
+ dev-perl/libwww-perl
+ >=dev-perl/LWP-Protocol-https-6.20.0
+"
+
+export OPTIMIZE="${CFLAGS}"
+#myconf="--lib=${EPREFIX}/usr"
+
+SRC_TEST=do