summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-03 02:21:33 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-03 02:21:33 +1200
commitd636ee27e76e0bfe0c954eddbcda8350c52cadab (patch)
tree9c3fb0810b4b3ef324e51aca21bce9976e7955be /dev-perl
parentdev-perl/Crypt-SmbHash: -r bump for EAPI7 + fixes (diff)
downloadgentoo-d636ee27e76e0bfe0c954eddbcda8350c52cadab.tar.gz
gentoo-d636ee27e76e0bfe0c954eddbcda8350c52cadab.tar.bz2
gentoo-d636ee27e76e0bfe0c954eddbcda8350c52cadab.zip
dev-perl/Crypt-Twofish: -r bump for EAPI7 + fixes
- EAPI7 - remove empty/unused variable assignments - Parallel tests - Ensure CFLAGS passed to make/compile Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r2.ebuild b/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r2.ebuild
new file mode 100644
index 000000000000..d144fc5de02c
--- /dev/null
+++ b/dev-perl/Crypt-Twofish/Crypt-Twofish-2.170.0-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=AMS
+DIST_VERSION=2.17
+inherit perl-module
+
+DESCRIPTION="The Twofish Encryption Algorithm"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+PATCHES=("${FILESDIR}/no-dot-inc.patch")
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}