summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-14 06:21:46 +0000
committerSam James <sam@gentoo.org>2021-12-14 06:21:46 +0000
commitdb40847290102119b36c3d2fe379f01267cda109 (patch)
tree7e7d4bddbd5812aab86ce11e17f517eafa7fbca7 /dev-perl
parentmount-boot.eclass: support EAPI 8 (diff)
downloadgentoo-db40847290102119b36c3d2fe379f01267cda109.tar.gz
gentoo-db40847290102119b36c3d2fe379f01267cda109.tar.bz2
gentoo-db40847290102119b36c3d2fe379f01267cda109.zip
dev-perl/XML-Parser: restore 2.440.0
This reverts commit d9e7940f92101dfc97efd94d6c60a45a17c4c234. Let users downgrade / mask a newer version if they want to for now while we investigate issues with the newer version. Bug: https://bugs.gentoo.org/827966 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/XML-Parser/Manifest1
-rw-r--r--dev-perl/XML-Parser/XML-Parser-2.440.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/XML-Parser/Manifest b/dev-perl/XML-Parser/Manifest
index d8458205f03d..ddc482776f3f 100644
--- a/dev-perl/XML-Parser/Manifest
+++ b/dev-perl/XML-Parser/Manifest
@@ -1 +1,2 @@
+DIST XML-Parser-2.44.tar.gz 237377 BLAKE2B 3d45053b98ef6944122fc4e61a8dd9bf25b3313d635c043ac065387befe2222b52c9963d1f9c5bceb45d7e288f13a6a83a39ccbed8ab2806867d379565199ecf SHA512 4790d20d89478880b18255679727e5b2fb2860bb4de67d5032c805fd44c9f90697a240a612aba51255325192253aa578b346d658b29f631a4e92ad96e7d65b61
DIST XML-Parser-2.46.tar.gz 254763 BLAKE2B a815c8f517adb609a1690e6127660eb339649eacffb21d77664b4f9ea071fbaeb432f50bc6469cb36a6b9b4b4e037f778dd2289bed6d87f497713d1d8cab9d0e SHA512 c4609495cc5ca34952f61876a690ef76d42eee6689d1bedb8036c9eab918525ec5213f1639c7178c029ee0f8765a2ca5eb0197f6e39b8be6d5dbc3f3c1d0b389
diff --git a/dev-perl/XML-Parser/XML-Parser-2.440.0.ebuild b/dev-perl/XML-Parser/XML-Parser-2.440.0.ebuild
new file mode 100644
index 000000000000..744eee96e008
--- /dev/null
+++ b/dev-perl/XML-Parser/XML-Parser-2.440.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=TODDR
+MODULE_VERSION=2.44
+inherit perl-module multilib
+
+DESCRIPTION="A Perl extension interface to James Clark's XML parser, expat"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/expat-1.95.1-r1"
+DEPEND="${RDEPEND}"
+
+SRC_TEST=do
+
+src_configure() {
+ myconf="EXPATLIBPATH=${EPREFIX}/usr/$(get_libdir) EXPATINCPATH=${EPREFIX}/usr/include"
+ perl-module_src_configure
+}