summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-18 13:41:48 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-18 13:42:15 +1200
commite7c0283cfa2037b30c4013e5bcc7b91f06a9d1ea (patch)
treeadc970a7a8fe63a5cc973e51c69bf025d49852fe /dev-perl
parentnet-dns/bind-tools: x86 stable (bug #728590) (diff)
downloadgentoo-e7c0283cfa2037b30c4013e5bcc7b91f06a9d1ea.tar.gz
gentoo-e7c0283cfa2037b30c4013e5bcc7b91f06a9d1ea.tar.bz2
gentoo-e7c0283cfa2037b30c4013e5bcc7b91f06a9d1ea.zip
dev-perl/Data-Structure-Util: -r bump for EAPI7 + CFLAGS love
- EAPI7 - Ensure CFLAGS passed to make/compiler - Strip bad tests unconditionally - Remove bundled build time inc/ in favour of BDEPEND Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Data-Structure-Util/Data-Structure-Util-0.160.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Data-Structure-Util/Data-Structure-Util-0.160.0-r1.ebuild b/dev-perl/Data-Structure-Util/Data-Structure-Util-0.160.0-r1.ebuild
new file mode 100644
index 000000000000..7065fb8c529c
--- /dev/null
+++ b/dev-perl/Data-Structure-Util/Data-Structure-Util-0.160.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ANDYA
+DIST_VERSION=0.16
+inherit perl-module
+
+DESCRIPTION="Change nature of data within a structure"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ >=virtual/perl-Scalar-List-Utils-1.10.0
+ virtual/perl-Storable
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/Devel-CheckLib
+ test? ( virtual/perl-Test-Simple )
+"
+PERL_RM_FILES=(
+ "t/00pod.t"
+ "t/06signature.t"
+ "inc/IO/CaptureOutput.pm"
+ "inc/IO/Devel/CheckLib.pm"
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}