summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-01-18 23:50:20 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-01-18 23:50:38 +0100
commitf2e30693a9587b0db81ce33388f1776ac05b1b96 (patch)
tree82bbe1c5464ab18d95e8c5fe2a7553f17efe5858 /dev-perl
parentdev-perl/Font-TTF: Remove old (diff)
downloadgentoo-f2e30693a9587b0db81ce33388f1776ac05b1b96.tar.gz
gentoo-f2e30693a9587b0db81ce33388f1776ac05b1b96.tar.bz2
gentoo-f2e30693a9587b0db81ce33388f1776ac05b1b96.zip
dev-perl/GD: Add a workaround for bug 572000; should build correctly now
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/GD/GD-2.560.0-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-perl/GD/GD-2.560.0-r1.ebuild b/dev-perl/GD/GD-2.560.0-r1.ebuild
new file mode 100644
index 000000000000..9366bb032eaa
--- /dev/null
+++ b/dev-perl/GD/GD-2.560.0-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=LDS
+DIST_VERSION=2.56
+inherit perl-module
+
+DESCRIPTION="Interface to Thomas Boutell's gd library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="animgif gif jpeg png truetype xpm"
+
+RDEPEND="
+ virtual/perl-Math-Complex
+ >=media-libs/gd-2.0.33
+ png? (
+ media-libs/gd[png]
+ media-libs/libpng:0
+ sys-libs/zlib
+ )
+ jpeg? (
+ media-libs/gd[jpeg]
+ virtual/jpeg:0
+ )
+ truetype? (
+ media-libs/gd[truetype]
+ media-libs/freetype:2
+ )
+ xpm? (
+ media-libs/gd[xpm]
+ x11-libs/libXpm
+ )
+ gif? ( media-libs/giflib )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+PREFER_BUILDPL="no"
+
+src_prepare(){
+ perl-module_src_prepare
+
+ # bug 572000
+ ln -s "${S}"/lib/GD.xs "${S}"/GD.xs
+
+ sed -i "s/use Getopt::Long;/use Getopt::Long qw(:config pass_through);/" \
+ "${S}"/Makefile.PL || die
+}
+
+src_configure() {
+ local myconf
+ use gif && use animgif && myconf+=",ANIMGIF"
+ use jpeg && myconf+=",JPEG"
+ use truetype && myconf+=",FT"
+ use png && myconf+=",PNG"
+ use xpm && myconf+=",XPM"
+ use gif && myconf+=",GIF"
+ myconf="-options '${myconf:1}'"
+ perl-module_src_configure
+}
+
+mydoc="GD.html"