summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-30 23:18:26 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-30 23:18:43 +1200
commitfa4a75664461abcb9d4df45147c966486d60a574 (patch)
tree4b2b2db6aeeb4ad9522faf8583e27f178244bd31 /dev-perl
parentdev-python/csv23: Fix pypy3 compat (diff)
downloadgentoo-fa4a75664461abcb9d4df45147c966486d60a574.tar.gz
gentoo-fa4a75664461abcb9d4df45147c966486d60a574.tar.bz2
gentoo-fa4a75664461abcb9d4df45147c966486d60a574.zip
dev-perl/Authen-SCRAM: EAPI7 migration, LICENSE correction
Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Authen-SCRAM/Authen-SCRAM-0.11.0-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Authen-SCRAM/Authen-SCRAM-0.11.0-r1.ebuild b/dev-perl/Authen-SCRAM/Authen-SCRAM-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..25929ce1e968
--- /dev/null
+++ b/dev-perl/Authen-SCRAM/Authen-SCRAM-0.11.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=0.011
+DIST_EXAMPLES=("devel/*")
+inherit perl-module
+
+DESCRIPTION="Salted Challenge Response Authentication Mechanism (RFC 5802)"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Authen-SASL-SASLprep
+ virtual/perl-Carp
+ dev-perl/Crypt-URandom
+ virtual/perl-Encode
+ virtual/perl-MIME-Base64
+ >=dev-perl/Moo-1.1.0
+ >=dev-perl/PBKDF2-Tiny-0.3.0
+ dev-perl/Try-Tiny
+ dev-perl/Type-Tiny
+ dev-perl/namespace-clean
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ virtual/perl-Exporter
+ virtual/perl-File-Spec
+ dev-perl/Test-FailWarnings
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"