summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/File_Iterator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/File_Iterator')
-rw-r--r--dev-php/File_Iterator/File_Iterator-1.3.1.ebuild17
-rw-r--r--dev-php/File_Iterator/File_Iterator-1.3.4.ebuild17
-rw-r--r--dev-php/File_Iterator/Manifest2
-rw-r--r--dev-php/File_Iterator/files/channel.xml16
-rw-r--r--dev-php/File_Iterator/metadata.xml8
5 files changed, 60 insertions, 0 deletions
diff --git a/dev-php/File_Iterator/File_Iterator-1.3.1.ebuild b/dev-php/File_Iterator/File_Iterator-1.3.1.ebuild
new file mode 100644
index 000000000000..aaa1bd180a99
--- /dev/null
+++ b/dev-php/File_Iterator/File_Iterator-1.3.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PHP_PEAR_URI="pear.phpunit.de"
+PHP_PEAR_CHANNEL="${FILESDIR}/channel.xml"
+PHP_PEAR_PN="File_Iterator"
+inherit php-pear-lib-r1
+
+DESCRIPTION="FilterIterator implementation that filters files based on a list of suffixes"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 hppa x86"
+IUSE=""
+HOMEPAGE="http://www.phpunit.de"
diff --git a/dev-php/File_Iterator/File_Iterator-1.3.4.ebuild b/dev-php/File_Iterator/File_Iterator-1.3.4.ebuild
new file mode 100644
index 000000000000..d82f56c1e1a0
--- /dev/null
+++ b/dev-php/File_Iterator/File_Iterator-1.3.4.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PHP_PEAR_URI="pear.phpunit.de"
+PHP_PEAR_CHANNEL="${FILESDIR}/channel.xml"
+PHP_PEAR_PN="File_Iterator"
+inherit php-pear-lib-r1
+
+DESCRIPTION="FilterIterator implementation that filters files based on a list of suffixes"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 hppa x86"
+IUSE=""
+HOMEPAGE="https://github.com/sebastianbergmann/php-file-iterator"
diff --git a/dev-php/File_Iterator/Manifest b/dev-php/File_Iterator/Manifest
new file mode 100644
index 000000000000..93c5099fd90a
--- /dev/null
+++ b/dev-php/File_Iterator/Manifest
@@ -0,0 +1,2 @@
+DIST File_Iterator-1.3.1.tgz 5157 SHA256 9a35bf5247c19988bb3033e10bbc2db0e25b174d231082c48f9639b3acb6aca1 SHA512 c5204fc5e10a713d474d5d42e728c0c52b89b214bd8d98c8918bef023511be8c86267c76656667ba49ca9d6252fb9156dc08c712556f49f8e1989ec11016fe7b WHIRLPOOL 4d0187fa41a5a82f5dbb0432c53c5fd2fc3ff73bf4171a1511e5b025e9d71981991bcb892c08ca61a0f692e302a5d5652d831da9d3ce3510678f57a43b08249d
+DIST File_Iterator-1.3.4.tgz 5199 SHA256 6f4ed93fc140aac0abb9d23313fa25c98789855a7d08088256c989a037730f7f SHA512 7117e0e56a9bc533d9f93556366a8026d1e5a9a3894c05551adef6c1e6cd556c1ebf6b96bd98279cb92077b3d8f8d7b7e42f446b39895850e573d0ec511392be WHIRLPOOL 6f7e4a589642ea3b6b0abbbb17b330f504153486b49840472a98cb6bb0fdb53447bdd994d3c112666f8c94ea8737e42bcf079c0785f1564f288319485dbeb1a7
diff --git a/dev-php/File_Iterator/files/channel.xml b/dev-php/File_Iterator/files/channel.xml
new file mode 100644
index 000000000000..91bb6786f543
--- /dev/null
+++ b/dev-php/File_Iterator/files/channel.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<channel version="1.0" xmlns="http://pear.php.net/channel-1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://pear.php.net/channel-1.0 http://pear.php.net/dtd/channel-1.0.xsd">
+ <name>pear.phpunit.de</name>
+ <summary>PHPUnit PEAR Channel</summary>
+ <suggestedalias>phpunit</suggestedalias>
+ <servers>
+ <primary>
+ <rest>
+ <baseurl type="REST1.0">http://pear.phpunit.de/rest/</baseurl>
+ <baseurl type="REST1.1">http://pear.phpunit.de/rest/</baseurl>
+ <baseurl type="REST1.2">http://pear.phpunit.de/rest/</baseurl>
+ <baseurl type="REST1.3">http://pear.phpunit.de/rest/</baseurl>
+ </rest>
+ </primary>
+ </servers>
+</channel> \ No newline at end of file
diff --git a/dev-php/File_Iterator/metadata.xml b/dev-php/File_Iterator/metadata.xml
new file mode 100644
index 000000000000..ff6ef25f6521
--- /dev/null
+++ b/dev-php/File_Iterator/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <upstream>
+ <remote-id type="github">sebastianbergmann/php-file-iterator</remote-id>
+ </upstream>
+</pkgmetadata>