summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-28 10:04:07 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-28 10:37:46 -0400
commit96d514fd3be1d69ff4da6fdc25131d0fec8fdbcc (patch)
treefaf52d66d4800fa5745af372f7267529282738ff /dev-php/PEAR-Archive_Tar
parentdev-java/oracle-jre-bin: Remove vulnerable 1.8.0.92 wrt bug #589208 (diff)
downloadgentoo-96d514fd3be1d69ff4da6fdc25131d0fec8fdbcc.tar.gz
gentoo-96d514fd3be1d69ff4da6fdc25131d0fec8fdbcc.tar.bz2
gentoo-96d514fd3be1d69ff4da6fdc25131d0fec8fdbcc.zip
dev-php/PEAR-Archive_Tar: new revision to clean up dependencies.
This package had a build-time dependency on dev-lang/php that was intended to be a runtime dependency; now fixed. There were also redundant dependencies on dev-php/pear and dev-php/PEAR-PEAR (which are the same, for all intents and purposes). The dev-php/pear dependency has been removed in favor of a single PDEPEND on dev-php/PEAR-PEAR. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-php/PEAR-Archive_Tar')
-rw-r--r--dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.2-r2.ebuild (renamed from dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.2-r1.ebuild)24
1 files changed, 12 insertions, 12 deletions
diff --git a/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.2-r1.ebuild b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.2-r2.ebuild
index d0d4b2045c63..4012f542efa5 100644
--- a/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.2-r1.ebuild
+++ b/dev-php/PEAR-Archive_Tar/PEAR-Archive_Tar-1.4.2-r2.ebuild
@@ -2,31 +2,31 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="6"
+EAPI=6
MY_PN="${PN/PEAR-/}"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Tar file management class"
-
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE=""
-SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
-DEPEND="dev-lang/php:*[pcre(+)]
- >=dev-php/PEAR-PEAR-1.9.0
-"
-RDEPEND="dev-lang/php:*[bzip2,zlib]
- ${DEPEND}"
-PDEPEND="dev-php/pear"
-HOMEPAGE="http://pear.php.net/package/Archive_Tar"
+
+# bzip2 and zlib are needed for compressed tarballs, and there's one
+# call to preg_match to test paths against a pattern of files and
+# directories that will be ignored.
+RDEPEND="dev-lang/php:*[bzip2,pcre(+),zlib]"
+PDEPEND="dev-php/PEAR-PEAR"
+DEPEND=""
S="${WORKDIR}/${MY_P}"
src_install() {
- insinto /usr/share/php/Archive
- doins Archive/*
+ insinto /usr/share/php
+ doins -r Archive
dodoc docs/*
}