summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-03-19 10:09:37 -0400
committerBrian Evans <grknight@gentoo.org>2017-03-19 10:26:30 -0400
commite7e2602102f31b30d18adce8ea25d6caff3b110d (patch)
tree4fe0c63be5c33c8a0ad86aa215fb7cd48c79718d /dev-php/PEAR-Console_Table
parentdev-lang/ispc: fix deps (bug #613178) (diff)
downloadgentoo-e7e2602102f31b30d18adce8ea25d6caff3b110d.tar.gz
gentoo-e7e2602102f31b30d18adce8ea25d6caff3b110d.tar.bz2
gentoo-e7e2602102f31b30d18adce8ea25d6caff3b110d.zip
dev-php/PEAR-Console_Table: Revision bump to fix WORKDIR wrt bug 613122
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-php/PEAR-Console_Table')
-rw-r--r--dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.0-r1.ebuild18
-rw-r--r--dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.0.ebuild34
2 files changed, 18 insertions, 34 deletions
diff --git a/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.0-r1.ebuild b/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..e3fb66073a4a
--- /dev/null
+++ b/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.0-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Class that makes it easy to build console style tables"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_install() {
+ insinto /usr/share/php/Console
+ doins Table.php
+ php-pear-r2_install_packagexml
+}
diff --git a/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.0.ebuild b/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.0.ebuild
deleted file mode 100644
index 0b5cf30702ee..000000000000
--- a/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PN="${PN/PEAR-/}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Class that makes it easy to build console style tables"
-HOMEPAGE="http://pear.php.net/package/${MY_PN}"
-SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND="dev-php/PEAR-PEAR dev-lang/php:*"
-
-S="${WORKDIR}/${MY_P}"
-
-src_install() {
- insinto /usr/share/php/Console
- doins Table.php
-}
-
-pkg_postinst() {
- # Register the package from the package.xml file
- "${EROOT}usr/bin/peardev" install -nrO --force "${WORKDIR}/package.xml" 2> /dev/null || die
-}
-
-pkg_postrm() {
- # Uninstall known dependency
- "${EROOT}usr/bin/peardev" uninstall -nrO "pear.php.net/${MY_PN}"
-}