summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-06-15 01:28:35 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-15 01:30:31 +0200
commit1f12b61377e0e886275754c9b928d9b16525ca89 (patch)
treebf49252a0d85f1ff22263ec67305f32bc0bc7f5d /dev-php/PEAR-Crypt_GPG
parentdev-php/doctrine-instantiator: bump to v1.3.1 (diff)
downloadgentoo-1f12b61377e0e886275754c9b928d9b16525ca89.tar.gz
gentoo-1f12b61377e0e886275754c9b928d9b16525ca89.tar.bz2
gentoo-1f12b61377e0e886275754c9b928d9b16525ca89.zip
dev-php/PEAR-Crypt_GPG: bump to v1.6.4
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-Crypt_GPG')
-rw-r--r--dev-php/PEAR-Crypt_GPG/Manifest1
-rw-r--r--dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-php/PEAR-Crypt_GPG/Manifest b/dev-php/PEAR-Crypt_GPG/Manifest
index bf34db2b470d..56adfac25354 100644
--- a/dev-php/PEAR-Crypt_GPG/Manifest
+++ b/dev-php/PEAR-Crypt_GPG/Manifest
@@ -1,2 +1,3 @@
DIST Crypt_GPG-1.6.2.tgz 346709 BLAKE2B abced2fe8c909f06690c38884506ce03df4c5ef3ef460aafce65ea9405c6974f8af320fd5a07a7967b45421a9a67aa27026c28ef7eb1402ffefba527007a33ae SHA512 9d954d96b4e461c75f79ce9bc701d062e3f19671690228e6e0ce5265733ac1de9c06520f9f750348f3c37f01ccb79720574b2d2f371e69c8a25ae6e1bc18aabd
DIST Crypt_GPG-1.6.3.tgz 346999 BLAKE2B 8402ef382a6393972a3fda7370fbd37dec19d0ebabb6b316d35783538dbc01746476977d7dc3da487876201cd678964d9572dc67a43911319b1b614004a3c909 SHA512 f1ad2560a43a1e8f5a33269bc4ae4067e19e5325fdbd8d2fc55f6cb8aad89258df45fbecedd93a21749f33024c819f07399580b1a4760f5740f26043109dc396
+DIST Crypt_GPG-1.6.4.tgz 346390 BLAKE2B 22e9e9d893f96bb3c3dc538b168a35366d2b699e92bf832370223879e90e8018cfd3b736e099807fdcc897b7569a40af66e72f011eaeb7400477053b7838409d SHA512 3eee39702abe97fc322e5976ebe8a7f7ba07bc950d22aa6636cadf38b0bd9c6c6316d7be35f21a8d0e8dfdb66a76db33121edb34736869d31ae89b03468cf470
diff --git a/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.4.ebuild b/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.4.ebuild
new file mode 100644
index 000000000000..46eb948e97d4
--- /dev/null
+++ b/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/PEAR-/}"
+MY_PV="${PV/_/}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="PHP interface to the GNU Privacy Guard (GnuPG)"
+HOMEPAGE="https://pear.php.net/package/Crypt_GPG"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-crypt/gnupg
+ dev-lang/php:*[posix,unicode]
+ dev-php/PEAR-Console_CommandLine
+ dev-php/PEAR-Exception"
+BDEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ sed -i "s|@bin-dir@|${EPREFIX}/usr/bin|" Crypt/GPG/Engine.php || die
+ sed -i "s|@package-name@|${MY_PN}|" Crypt/GPG/PinEntry.php || die
+ sed -i "s|@data-dir@|${EPREFIX}/usr/share|" Crypt/GPG/PinEntry.php || die
+}
+
+src_install() {
+ dodoc README.md
+ dobin scripts/crypt-gpg-pinentry
+
+ insinto "/usr/share/${MY_PN}"
+ doins -r data
+
+ insinto /usr/share/php
+ doins -r Crypt
+}
+
+src_test() {
+ phpunit tests/ || die "test suite failed"
+}