summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-02-02 14:51:05 -0500
committerBrian Evans <grknight@gentoo.org>2021-02-02 14:51:05 -0500
commite3cc58f44c5055f87d71c5b55122813a9e880a37 (patch)
tree11df8d1eb10bb127d7e4ed6eed53eedce522b400 /dev-php/PEAR-Crypt_GPG
parentdev-util/indent: EAPI-7 bump, swap out eutils with l10n.eclass (diff)
downloadgentoo-e3cc58f44c5055f87d71c5b55122813a9e880a37.tar.gz
gentoo-e3cc58f44c5055f87d71c5b55122813a9e880a37.tar.bz2
gentoo-e3cc58f44c5055f87d71c5b55122813a9e880a37.zip
dev-php/PEAR-Crypt_GPG: Fix unit tests for phpunit-8
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-Crypt_GPG')
-rw-r--r--dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.4.ebuild6
-rw-r--r--dev-php/PEAR-Crypt_GPG/files/1.6.4-fix-tests.patch45
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.4.ebuild b/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.4.ebuild
index e0cea4ce1b04..720a949b0606 100644
--- a/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.4.ebuild
+++ b/dev-php/PEAR-Crypt_GPG/PEAR-Crypt_GPG-1.6.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,7 +20,9 @@ RDEPEND="app-crypt/gnupg
dev-lang/php:*[posix,unicode]
dev-php/PEAR-Console_CommandLine
dev-php/PEAR-Exception"
-BDEPEND="test? ( ${RDEPEND} <dev-php/phpunit-6 )"
+BDEPEND="test? ( ${RDEPEND} <dev-php/phpunit-9 )"
+
+PATCHES=( "${FILESDIR}/1.6.4-fix-tests.patch" )
S="${WORKDIR}/${MY_P}"
diff --git a/dev-php/PEAR-Crypt_GPG/files/1.6.4-fix-tests.patch b/dev-php/PEAR-Crypt_GPG/files/1.6.4-fix-tests.patch
new file mode 100644
index 000000000000..e4fb835cc34f
--- /dev/null
+++ b/dev-php/PEAR-Crypt_GPG/files/1.6.4-fix-tests.patch
@@ -0,0 +1,45 @@
+diff -uarN a/tests/ImportKeyTest.php b/tests/ImportKeyTest.php
+--- a/tests/ImportKeyTest.php 2020-03-22 08:00:23.000000000 -0400
++++ b/tests/ImportKeyTest.php 2021-02-02 14:45:16.561963089 -0500
+@@ -60,7 +60,7 @@
+ // set up
+ // {{{ setUp()
+
+- public function setUp()
++ public function setUp() :void
+ {
+ parent::setUp();
+
+diff -uarN a/tests/KeyGeneratorTest.php b/tests/KeyGeneratorTest.php
+--- a/tests/KeyGeneratorTest.php 2020-03-22 08:00:23.000000000 -0400
++++ b/tests/KeyGeneratorTest.php 2021-02-02 14:42:07.117718685 -0500
+@@ -174,7 +174,7 @@
+ // }}}
+ // {{{ setUp()
+
+- public function setUp()
++ public function setUp() :void
+ {
+ parent::setUp();
+ $this->generator = new Crypt_GPG_KeyGenerator($this->getOptions());
+diff -uarN a/tests/TestCase.php b/tests/TestCase.php
+--- a/tests/TestCase.php 2020-03-22 08:00:23.000000000 -0400
++++ b/tests/TestCase.php 2021-02-02 14:42:36.978387716 -0500
+@@ -119,7 +119,7 @@
+ // set up
+ // {{{ setUp()
+
+- public function setUp()
++ public function setUp() :void
+ {
+ // load test configuration file if it exists
+ $configFilename = __DIR__ . '/config.php';
+@@ -567,7 +567,7 @@
+ // }}}
+ // {{{ tearDown()
+
+- public function tearDown()
++ public function tearDown() :void
+ {
+ unset($this->gpg);
+