summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-19 09:43:55 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-19 10:19:57 -0500
commit136aaeec57f5e3cc9d9d99c5fdde58815b48fed0 (patch)
tree3ec717fd4445c89c80374031d1c498e930d04b55 /dev-php/PEAR-HTML_Template_Sigma
parentmedia-sound/soundkonverter: Prepare for media-libs/phonon losing qt5 (diff)
downloadgentoo-136aaeec57f5e3cc9d9d99c5fdde58815b48fed0.tar.gz
gentoo-136aaeec57f5e3cc9d9d99c5fdde58815b48fed0.tar.bz2
gentoo-136aaeec57f5e3cc9d9d99c5fdde58815b48fed0.zip
dev-php/PEAR-HTML_Template_Sigma: Straight to stable revbump
Add required constructor and tests patch Enable tests Bump EAPI Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/PEAR-HTML_Template_Sigma')
-rw-r--r--dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild20
-rw-r--r--dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0.ebuild14
-rw-r--r--dev-php/PEAR-HTML_Template_Sigma/files/HTML_Template_Sigma-1.3.0-php7.patch42
3 files changed, 62 insertions, 14 deletions
diff --git a/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild b/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..828f16ce507e
--- /dev/null
+++ b/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="An implementation of Integrated Templates API with template 'compilation' added"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="test"
+
+RDEPEND="dev-lang/php:*[ctype]"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+PATCHES=( "${FILESDIR}/HTML_Template_Sigma-1.3.0-php7.patch" )
+
+src_test() {
+ phpunit tests/AllTests.php || die
+}
diff --git a/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0.ebuild b/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0.ebuild
deleted file mode 100644
index dfde6e232ff2..000000000000
--- a/dev-php/PEAR-HTML_Template_Sigma/PEAR-HTML_Template_Sigma-1.3.0.ebuild
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit php-pear-r1
-
-DESCRIPTION="An implementation of Integrated Templates API with template 'compilation' added"
-LICENSE="PHP-3.01"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-DEPEND="dev-lang/php[ctype]"
diff --git a/dev-php/PEAR-HTML_Template_Sigma/files/HTML_Template_Sigma-1.3.0-php7.patch b/dev-php/PEAR-HTML_Template_Sigma/files/HTML_Template_Sigma-1.3.0-php7.patch
new file mode 100644
index 000000000000..ffb95e208467
--- /dev/null
+++ b/dev-php/PEAR-HTML_Template_Sigma/files/HTML_Template_Sigma-1.3.0-php7.patch
@@ -0,0 +1,42 @@
+diff -aurN a/HTML/Template/Sigma.php b/HTML/Template/Sigma.php
+--- a/HTML/Template/Sigma.php 2014-01-13 04:33:52.000000000 -0500
++++ b/HTML/Template/Sigma.php 2018-02-19 09:29:52.995013991 -0500
+@@ -384,6 +384,26 @@
+ *
+ * @see setRoot(), setCacheRoot()
+ */
++ function __construct($root = '', $cacheRoot = '')
++ {
++ // the class is inherited from PEAR to be able to use $this->setErrorHandling()
++ parent::__construct();
++ $this->variablesRegExp = '@' . $this->openingDelimiter . '(' . $this->variablenameRegExp . ')' .
++ '(:(' . $this->functionnameRegExp . '))?' . $this->closingDelimiter . '@sm';
++ $this->removeVariablesRegExp = '@' . $this->openingDelimiter . '\s*(' . $this->variablenameRegExp . ')\s*'
++ . $this->closingDelimiter . '@sm';
++ $this->blockRegExp = '@<!--\s+BEGIN\s+(' . $this->blocknameRegExp
++ . ')\s+-->(.*)<!--\s+END\s+\1\s+-->@sm';
++ $this->functionRegExp = '@' . $this->functionPrefix . '(' . $this->functionnameRegExp . ')\s*\(@sm';
++ $this->setRoot($root);
++ $this->setCacheRoot($cacheRoot);
++
++ $this->setCallbackFunction('h', array(&$this, '_htmlspecialchars'));
++ $this->setCallbackFunction('e', array(&$this, '_htmlentities'));
++ $this->setCallbackFunction('u', 'urlencode');
++ $this->setCallbackFunction('r', 'rawurlencode');
++ $this->setCallbackFunction('j', array(&$this, '_jsEscape'));
++ }
+ function HTML_Template_Sigma($root = '', $cacheRoot = '')
+ {
+ // the class is inherited from PEAR to be able to use $this->setErrorHandling()
+diff -aurN a/tests/AllTests.php b/tests/AllTests.php
+--- a/tests/AllTests.php 2014-01-13 04:33:52.000000000 -0500
++++ b/tests/AllTests.php 2018-02-19 09:37:14.071972780 -0500
+@@ -24,8 +24,6 @@
+ define('PHPUnit_MAIN_METHOD', 'HTML_Template_Sigma_AllTests::main');
+ }
+
+-require_once 'PHPUnit/Autoload.php';
+-
+ /**
+ * Class for file / directory manipulation from PEAR package
+ */