summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-09-30 18:29:12 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-09-30 20:03:44 +0200
commitc579df74d0a6c2438e495280072ce77070c491fe (patch)
tree138adfc4cd4fdd24d4d402eac10044bd2e3a848a /dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.4.2.ebuild
parentdev-php/pecl-mailparse: bump to v3.1.1 (diff)
downloadgentoo-c579df74d0a6c2438e495280072ce77070c491fe.tar.gz
gentoo-c579df74d0a6c2438e495280072ce77070c491fe.tar.bz2
gentoo-c579df74d0a6c2438e495280072ce77070c491fe.zip
dev-php/PEAR-HTTP_Request2: bump to v2.4.2
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.4.2.ebuild')
-rw-r--r--dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.4.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.4.2.ebuild b/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.4.2.ebuild
new file mode 100644
index 000000000000..b1f6817200a1
--- /dev/null
+++ b/dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit php-pear-r2
+
+DESCRIPTION="Provides an easy way to perform HTTP requests"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="+curl +fileinfo +ssl test +zlib"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/php:*[curl?,fileinfo?,ssl?,zlib?]
+>=dev-php/PEAR-Net_URL2-2.2.0"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+src_prepare() {
+ sed -i "s~@data_dir@~${EPREFIX}/usr/share/php/data~" HTTP/Request2/CookieJar.php || die
+ default
+}
+
+src_test() {
+ phpunit tests || die
+}
+
+src_install() {
+ php-pear-r2_src_install
+ insinto "/usr/share/php/data/${PHP_PEAR_PKG_NAME}"
+ doins data/*
+}