summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-15 11:51:28 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-15 11:53:40 -0500
commitc5a8d924447d3cfb98c5f6e66506b56313346a01 (patch)
tree4a4cf5c7f992ef1145a0c1226f42c45a43d796fd /dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild
parentdev-php/PEAR-Text_CAPTCHA_Numeral: Drop old revision (diff)
downloadgentoo-c5a8d924447d3cfb98c5f6e66506b56313346a01.tar.gz
gentoo-c5a8d924447d3cfb98c5f6e66506b56313346a01.tar.bz2
gentoo-c5a8d924447d3cfb98c5f6e66506b56313346a01.zip
dev-php/PEAR-Services_JSON: Revbump for EAPI, eclass and constructor
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild')
-rw-r--r--dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild b/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..7203bc34815a
--- /dev/null
+++ b/dev-php/PEAR-Services_JSON/PEAR-Services_JSON-1.0.3-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+IUSE=""
+DESCRIPTION="PHP implementaion of json_encode/decode"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+PATCHES=( "${FILESDIR}/JSON-1.0.3-constructor.patch" )
+
+src_install() {
+ php-pear-r2_src_install
+ insinto /usr/share/php/Services
+ doins JSON.php
+}