summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-02-03 18:15:02 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-02-03 18:15:18 -0500
commit597b7a2a168475989a9b5c21e16319dcbb886fe3 (patch)
tree3fb0cb3601b78e3fd372938c3d4877cad620caa7 /dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild
parentsys-fs/ddrescue: Bump to version 1.22 (diff)
downloadgentoo-597b7a2a168475989a9b5c21e16319dcbb886fe3.tar.gz
gentoo-597b7a2a168475989a9b5c21e16319dcbb886fe3.tar.bz2
gentoo-597b7a2a168475989a9b5c21e16319dcbb886fe3.zip
dev-php/PEAR-Text_Password: new version 1.2.1.
This new version updates to EAPI=6 and drops the php-pear-r1 eclass. Dropping the eclass was even more appropriate than usual in this case, since the package makes no use of PEAR at all. The test suite (using PHPUnit) was also enabled. The ia64, ppc, ppc64, and sparc keywords were dropped for that. Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild')
-rw-r--r--dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild b/dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild
new file mode 100644
index 000000000000..edc3f2ce71da
--- /dev/null
+++ b/dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Creating passwords with PHP"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~x86"
+IUSE="test"
+
+RDEPEND="dev-lang/php:*"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Text
+}
+
+src_test() {
+ phpunit tests/ || die 'test suite failed'
+}