summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-03-09 10:45:38 -0500
committerBrian Evans <grknight@gentoo.org>2017-03-09 11:22:31 -0500
commitb7346b735e2b084474259f37b3b474ec9337efcb (patch)
tree247491c5a21d350e76af25cc42df998e638d2e8f /dev-php/Text_Template/Text_Template-1.2.1.ebuild
parentdev-php/phpspec-prophecy: New package for an unbundled phpunit (diff)
downloadgentoo-b7346b735e2b084474259f37b3b474ec9337efcb.tar.gz
gentoo-b7346b735e2b084474259f37b3b474ec9337efcb.tar.bz2
gentoo-b7346b735e2b084474259f37b3b474ec9337efcb.zip
dev-php/Text_Template: Version bump and use composer autoloading
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-php/Text_Template/Text_Template-1.2.1.ebuild')
-rw-r--r--dev-php/Text_Template/Text_Template-1.2.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/Text_Template/Text_Template-1.2.1.ebuild b/dev-php/Text_Template/Text_Template-1.2.1.ebuild
new file mode 100644
index 000000000000..030776279ea7
--- /dev/null
+++ b/dev-php/Text_Template/Text_Template-1.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="php-text-template"
+
+DESCRIPTION="A simple template engine"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/Text/Template
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}
+
+pkg_postinst() {
+ ewarn "This library now loads via /usr/share/php/Text/Template/autoload.php"
+ ewarn "Please update any scripts to require the autoloader"
+}