summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-04-21 09:36:00 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-04-21 09:38:44 -0400
commit53db769dc5145930f52953843761c4b81225060c (patch)
tree6096b9a4e498c4eba7a65257ae5443271efe0a15 /dev-php/awl/awl-0.61.ebuild
parentsys-kernel/gentoo-sources: Linux patch 5.6.6 (diff)
downloadgentoo-53db769dc5145930f52953843761c4b81225060c.tar.gz
gentoo-53db769dc5145930f52953843761c4b81225060c.tar.bz2
gentoo-53db769dc5145930f52953843761c4b81225060c.zip
dev-php/awl: new v0.61 to address CVE-2020-{11728,11729}.
Bug: https://bugs.gentoo.org/718736 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php/awl/awl-0.61.ebuild')
-rw-r--r--dev-php/awl/awl-0.61.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-php/awl/awl-0.61.ebuild b/dev-php/awl/awl-0.61.ebuild
new file mode 100644
index 000000000000..52ae69f3df6a
--- /dev/null
+++ b/dev-php/awl/awl-0.61.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Andrew McMillan's Web Libraries"
+HOMEPAGE="https://gitlab.com/davical-project/awl"
+SRC_URI="https://www.davical.org/downloads/${PN}_${PV}.orig.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-2 GPL-2+ GPL-3+ LGPL-2+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-php/phpunit )"
+RDEPEND="dev-lang/php:*[pdo,postgres,xml]"
+
+S="${WORKDIR}"
+
+src_compile() {
+ :
+}
+
+src_test() {
+ phpunit tests/ || die "test suite failed"
+}
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/php/${PN}
+ doins -r dba inc
+}