summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-04-27 16:13:34 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-04-27 16:28:18 +0200
commitb92d612030da47611d3bc49ec1f0e5f708730ca6 (patch)
tree5ce129886c5b499ae0b3e0402d8d3a38cbee7be7 /dev-php/composer/composer-1.10.22.ebuild
parentdev-java/hawtjni-runtime: removed obsolete 1.15 (diff)
downloadgentoo-b92d612030da47611d3bc49ec1f0e5f708730ca6.tar.gz
gentoo-b92d612030da47611d3bc49ec1f0e5f708730ca6.tar.bz2
gentoo-b92d612030da47611d3bc49ec1f0e5f708730ca6.zip
dev-php/composer: bump to v1.10.22
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/composer/composer-1.10.22.ebuild')
-rw-r--r--dev-php/composer/composer-1.10.22.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-php/composer/composer-1.10.22.ebuild b/dev-php/composer/composer-1.10.22.ebuild
new file mode 100644
index 000000000000..d8c51c550e91
--- /dev/null
+++ b/dev-php/composer/composer-1.10.22.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Dependency Manager for PHP"
+HOMEPAGE="https://github.com/composer/composer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/php:*[curl]
+ >=dev-php/ca-bundle-1.1.3
+ >=dev-php/psr-log-1.1.0
+ dev-php/fedora-autoloader
+ >=dev-php/json-schema-5.2.10
+ >=dev-php/jsonlint-1.7.1
+ >=dev-php/phar-utils-1.0.1
+ >=dev-php/semver-1.4.2
+ >=dev-php/spdx-licenses-1.5.0
+ >=dev-php/symfony-console-2.8.48
+ >=dev-php/symfony-filesystem-2.8.48
+ >=dev-php/symfony-finder-2.8.49
+ >=dev-php/symfony-process-2.8.48
+ >=dev-php/xdebug-handler-1.3.1"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+
+ # Composer expects the LICENSE file to be there, and the
+ # easiest thing to do is to give it what it wants.
+ doins -r src res LICENSE
+
+ insinto "/usr/share/${PN}/vendor"
+ newins "${FILESDIR}"/autoload-r1.php autoload.php
+
+ exeinto "/usr/share/${PN}/bin"
+ doexe "bin/${PN}"
+ dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+ dodoc CHANGELOG.md README.md doc/*.md
+ dodoc -r doc/articles doc/faqs
+}