summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-12-28 09:19:25 -0500
committerBrian Evans <grknight@gentoo.org>2021-12-28 09:20:00 -0500
commit58559e1030a00f957b4326ac194a8b400cdb88df (patch)
treea579842807de587c6ed7b4342e41fbee45c0c98a /dev-php/jpgraph
parentsci-chemistry/mdtraj: add version 1.9.7, enable py3.10, fix tests (diff)
downloadgentoo-58559e1030a00f957b4326ac194a8b400cdb88df.tar.gz
gentoo-58559e1030a00f957b4326ac194a8b400cdb88df.tar.bz2
gentoo-58559e1030a00f957b4326ac194a8b400cdb88df.zip
dev-php/jpgraph: Version bump for 4.3.5
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/jpgraph')
-rw-r--r--dev-php/jpgraph/Manifest1
-rw-r--r--dev-php/jpgraph/jpgraph-4.3.5.ebuild62
-rw-r--r--dev-php/jpgraph/metadata.xml1
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-php/jpgraph/Manifest b/dev-php/jpgraph/Manifest
index f234700eea72..3e079e09a2b1 100644
--- a/dev-php/jpgraph/Manifest
+++ b/dev-php/jpgraph/Manifest
@@ -1,2 +1,3 @@
DIST jpgraph-4.0.2.tar.gz 13298314 BLAKE2B 46506f5a3f331157329c92f61f4843faa7d0774fbdb0cafe58a5609d1c9e9c2f73d4634ffd09cad3c874a45b2ac8658271a343b5e0dfb673f810bf7af6083189 SHA512 db1877c09c13a26d24ef7df4aae50799f55c6d72ca0cdb0b8d8c05928c1bc860f8a86eb52a5fb05bdc1c07574931825baa2989f006e9a4cc57e60913e8b67a3e
DIST jpgraph-4.2.0.tar.gz 13298982 BLAKE2B b5fab9754239f78fbdfebd84872b824400d27fce89a80d82028d2521f7d64ada79efe4eb9c5460f56d882e827f5930eb10a57c3b41a81865dd618b9baf628cf9 SHA512 f0f164663f2e0fca5b827d89c57aaa144765a987ca4ebb82f18102f8cb80057c7f7639b8faae5d6d6ce459257bdfa609d2df6ffe648a7334c58c87ddfe86c334
+DIST jpgraph-4.3.5.tar.gz 13293351 BLAKE2B 246d2446b02b0f01fd8e3960d645897c21604c726541177aa5573620b63ab9a1f5d5318309e1c3ffd159257f02c0d1c7a7b8b563758abeea18161327a4939668 SHA512 7e826147f8f551171463d15add17f65587e879d6e666fcec9872367b7bdea77b2b1fd6b0af03984680d23dfe7c1e21b4f5d2cfd9a45a60c52b62812a5c1ab7ac
diff --git a/dev-php/jpgraph/jpgraph-4.3.5.ebuild b/dev-php/jpgraph/jpgraph-4.3.5.ebuild
new file mode 100644
index 000000000000..534e39c0355d
--- /dev/null
+++ b/dev-php/jpgraph/jpgraph-4.3.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Object-oriented graphing library for PHP"
+HOMEPAGE="http://jpgraph.net/"
+# Upstream didn't have a stable download URL when this was packaged.
+SRC_URI="https://dev.gentoo.org/~grknight/distfiles/${P}.tar.gz"
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="truetype examples"
+
+DEPEND=""
+RDEPEND="truetype? ( media-fonts/corefonts )
+ dev-lang/php[gd,truetype?]"
+
+src_prepare() {
+ default
+
+ # The DejaVu fonts are now bundled with the library and don't need
+ # to be found in TTF_DIR. Since most of the fonts supported by
+ # JpGraph are corefonts, we point the sole TTF_DIR towards them for
+ # maximum impact. Why not apply the patch unconditionally? We want
+ # to avoid a situation where TTF fonts appear to work, but then
+ # break without warning when the user e.g. removes corefonts. By
+ # applying the patch conditionally, we ensure a dependency on
+ # media-fonts/corefonts before anything will work.
+ use truetype && eapply "${FILESDIR}/gentoo_ttf_dir.patch"
+
+ # Some of the documentation and examples are shipped in the "src"
+ # directory. We want them outside of that tree so that we can simply
+ # call doins recursively on "src". First, rename the existing "docs"
+ # directory which contains the HTML manual and class reference.
+ mv docs html || die 'failed to rename "docs" directory'
+ mv src/README ./ || die 'failed to relocate the README'
+ mv src/Examples ./examples || die 'failed to relocate the examples'
+
+ # These are present (duplicated) in the other Examples directory,
+ # and don't work anyway.
+ rm -r src/barcode || die 'failed to remove some barcode examples'
+
+ # We'll also want to install the config file to /etc, since it may
+ # need to be edited by the user.
+ mv src/jpg-config.inc.php ./ || die 'failed to relocate the config file'
+}
+
+src_install() {
+ dodoc README
+ dodoc -r html
+ use examples && dodoc -r examples
+
+ insinto "/usr/share/php/${PN}"
+ doins -r src/*
+
+ insinto /etc
+ doins jpg-config.inc.php
+ # Create a symlink for the config file, because the library will only
+ # look for it in its own source tree (not in /etc where we've put it).
+ dosym ../../../../etc/jpg-config.inc.php "/usr/share/php/${PN}/jpg-config.inc.php"
+}
diff --git a/dev-php/jpgraph/metadata.xml b/dev-php/jpgraph/metadata.xml
index 222c77f3742a..666e6402df14 100644
--- a/dev-php/jpgraph/metadata.xml
+++ b/dev-php/jpgraph/metadata.xml
@@ -5,4 +5,5 @@
<email>php-bugs@gentoo.org</email>
<name>PHP</name>
</maintainer>
+ <stabilize-allarches />
</pkgmetadata>