summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2016-11-24 08:24:03 +0100
committerMichael Orlitzky <mjo@gentoo.org>2016-12-18 18:17:00 -0500
commit79a2aeb43a03a8a2529bed6a20d99fbcd3d1bbf8 (patch)
tree76a2b119405c9c2ac7b787c01d84c0027d58c94c /dev-php/json-schema
parentdev-php/cli-prompt: Add 1.0.0 version (diff)
downloadgentoo-79a2aeb43a03a8a2529bed6a20d99fbcd3d1bbf8.tar.gz
gentoo-79a2aeb43a03a8a2529bed6a20d99fbcd3d1bbf8.tar.bz2
gentoo-79a2aeb43a03a8a2529bed6a20d99fbcd3d1bbf8.zip
dev-php/json-schema: Add 2.0.0 version
This is needed for composer-1.2.2, bug 439206. Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php/json-schema')
-rw-r--r--dev-php/json-schema/Manifest1
-rw-r--r--dev-php/json-schema/files/autoload.php10
-rw-r--r--dev-php/json-schema/json-schema-2.0.0.ebuild23
-rw-r--r--dev-php/json-schema/metadata.xml15
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/json-schema/Manifest b/dev-php/json-schema/Manifest
new file mode 100644
index 000000000000..6c3b3eea62ef
--- /dev/null
+++ b/dev-php/json-schema/Manifest
@@ -0,0 +1 @@
+DIST json-schema-2.0.0.tar.gz 21319 SHA256 bdbaedf8be4bb2ceb8019c651b0579a4b9723dc95e11f0aa683cfe193064e392 SHA512 8efa6ad3175b474e3c073816651d77e80e3ec7865aa6a04f8c7eff7a91831ab1eb1b0b6968d542aa6d10e1e0a1171ec05889b817713f1d740afeb31c5f124a52 WHIRLPOOL 5af244685521d57b663faf78f287a978e7b8bb89526ad8f282fb7d57490540fd483501752bc27b75d6b2de9699d2684352a0e5711fed98b5c6e9cf2f0437b0d9
diff --git a/dev-php/json-schema/files/autoload.php b/dev-php/json-schema/files/autoload.php
new file mode 100644
index 000000000000..c8a6c8a8b715
--- /dev/null
+++ b/dev-php/json-schema/files/autoload.php
@@ -0,0 +1,10 @@
+<?php
+/**
+ * Autoloader for justinrainbow/json-schema and its dependencies
+ */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('JsonSchema\\', __DIR__);
diff --git a/dev-php/json-schema/json-schema-2.0.0.ebuild b/dev-php/json-schema/json-schema-2.0.0.ebuild
new file mode 100644
index 000000000000..05f698221515
--- /dev/null
+++ b/dev-php/json-schema/json-schema-2.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="PHP implementation of JSON schema"
+HOMEPAGE="https://github.com/justinrainbow/json-schema"
+SRC_URI="https://github.com/justinrainbow/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+src_install() {
+ insinto "/usr/share/php/JsonSchema"
+ doins -r src/JsonSchema/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}
diff --git a/dev-php/json-schema/metadata.xml b/dev-php/json-schema/metadata.xml
new file mode 100644
index 000000000000..9912fb38cf6d
--- /dev/null
+++ b/dev-php/json-schema/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ A PHP Implementation for validating JSON Structures against a given Schema.
+ </longdescription>
+</pkgmetadata>