summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-09-14 00:59:34 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-09-14 01:17:46 +0200
commit6f7747c8d4468e611a37904fbbd7836cafa1faaa (patch)
tree9c02355900f6cd7330538879eeb4b988856f8bc8 /dev-php/jsonlint/jsonlint-1.8.2.ebuild
parentRevert "dev-util/intel-graphics-compiler: bump to 1.0.4427" (diff)
downloadgentoo-6f7747c8d4468e611a37904fbbd7836cafa1faaa.tar.gz
gentoo-6f7747c8d4468e611a37904fbbd7836cafa1faaa.tar.bz2
gentoo-6f7747c8d4468e611a37904fbbd7836cafa1faaa.zip
dev-php/jsonlint: bump to v1.8.2
Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/jsonlint/jsonlint-1.8.2.ebuild')
-rw-r--r--dev-php/jsonlint/jsonlint-1.8.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/jsonlint/jsonlint-1.8.2.ebuild b/dev-php/jsonlint/jsonlint-1.8.2.ebuild
new file mode 100644
index 000000000000..a042e788cfa7
--- /dev/null
+++ b/dev-php/jsonlint/jsonlint-1.8.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="JSON Lint for PHP"
+HOMEPAGE="https://github.com/Seldaek/jsonlint"
+SRC_URI="https://github.com/Seldaek/jsonlint/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-php/phpunit
+ )"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+ sed -i -e "s:__DIR__:'${S}/src/Seld/JsonLint':" "${S}"/autoload-test.php || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/Seld/JsonLint"
+ doins -r src/Seld/JsonLint/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
+}