summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-12-09 11:18:52 -0500
committerBrian Evans <grknight@gentoo.org>2020-12-09 11:18:52 -0500
commit1012d7ec9292877a699cc6ed28a9bacba13eeb1f (patch)
treecb8de76da75eb35bfab992eb746abb979de487b6 /dev-php/pecl-dbase
parentdev-php/pecl-dbase: Version bump for 7.1.0_rc2 (diff)
downloadgentoo-1012d7ec9292877a699cc6ed28a9bacba13eeb1f.tar.gz
gentoo-1012d7ec9292877a699cc6ed28a9bacba13eeb1f.tar.bz2
gentoo-1012d7ec9292877a699cc6ed28a9bacba13eeb1f.zip
pecl-dbase: Drop old targets from 7.0.1
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-dbase')
-rw-r--r--dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild33
1 files changed, 4 insertions, 29 deletions
diff --git a/dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild b/dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild
index 43d998a62c33..e39dbd9f0ad1 100644
--- a/dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild
+++ b/dev-php/pecl-dbase/pecl-dbase-7.0.1.ebuild
@@ -1,17 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-# Define 5.6 here so we get the USE and REQUIRED_USE from the eclass
-# This allows us to depend on the other slot
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3 php7-4"
+USE_PHP="php7-2 php7-3 php7-4"
inherit php-ext-pecl-r3
-# However, we only really build for 7.x; so redefine it here
-USE_PHP="php7-0 php7-1 php7-2 php7-3 php7-4"
-
KEYWORDS="~amd64 ~x86"
DESCRIPTION="dBase database file access functions"
@@ -20,25 +15,5 @@ SLOT="7"
IUSE=""
DEPEND=""
-RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-dbase:0[php_targets_php5-6] )"
-
-src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- php-ext-source-r3_src_prepare
- else
- eapply_user
- fi
-}
-
-src_configure() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- local PHP_EXT_ECONF_ARGS=( )
- php-ext-source-r3_src_configure
- fi
-}
-
-src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
- php-ext-pecl-r3_src_install
- fi
-}
+RDEPEND="${DEPEND}"
+PHP_EXT_ECONF_ARGS=( )