summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-01-20 21:49:22 -0500
committerBrian Evans <grknight@gentoo.org>2021-01-20 21:49:22 -0500
commit97877865cc9af4b640997811164c4e9eda396dd9 (patch)
tree3ee81cb4a6975ac745314567f9ac2b2fca255140 /dev-php/pecl-http/pecl-http-3.2.4.ebuild
parentdev-php/pecl-http: Version bump for 4.0.0 (diff)
downloadgentoo-97877865cc9af4b640997811164c4e9eda396dd9.tar.gz
gentoo-97877865cc9af4b640997811164c4e9eda396dd9.tar.bz2
gentoo-97877865cc9af4b640997811164c4e9eda396dd9.zip
dev-php/pecl-http: Version bump for 3.2.4
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-http/pecl-http-3.2.4.ebuild')
-rw-r--r--dev-php/pecl-http/pecl-http-3.2.4.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-php/pecl-http/pecl-http-3.2.4.ebuild b/dev-php/pecl-http/pecl-http-3.2.4.ebuild
new file mode 100644
index 000000000000..f4816f1ac8c3
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-3.2.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_INI_NAME="50-http"
+
+USE_PHP="php7-3 php7-4 php8-0"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php7-3 php7-4"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP"
+LICENSE="BSD-2 MIT"
+SLOT="7"
+IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
+
+COMMON_DEPEND="app-arch/brotli:=
+ dev-libs/libevent
+ dev-php/pecl-propro:7[php_targets_php7-3(-)?,php_targets_php7-4(-)?]
+ >=dev-php/pecl-raphf-2.0.1:7[php_targets_php7-3(-)?,php_targets_php7-4(-)?]
+ net-dns/libidn2
+ sys-libs/zlib
+ ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
+ !ssl? ( net-misc/curl[-ssl] )
+"
+DEPEND="
+ php_targets_php7-3? ( ${COMMON_DEPEND} dev-lang/php:7.3[hash,session,iconv] )
+ php_targets_php7-4? ( ${COMMON_DEPEND} dev-lang/php:7.4[session,iconv] )"
+RDEPEND="${DEPEND}
+ php_targets_php8-0? ( dev-php/pecl-http:8[php_targets_php8-0(-)] )"
+
+PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps --without-http-libidn-dir )
+
+src_prepare() {
+ if use php_targets_php7-3 || use php_targets_php7-4 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-3 || use php_targets_php7-4 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}
+
+src_test() {
+ # Cannot use eclass function due to required modules
+ # All tests SKIP otherwise
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Link in required modules for testing
+ ln -s "${EXT_DIR}/propro.so" "modules/propro.so" || die
+ ln -s "${EXT_DIR}/raphf.so" "modules/raphf.so" || die
+ sed -i \
+ 's/PHP_TEST_SHARED_EXTENSIONS)/PHP_TEST_SHARED_EXTENSIONS) -d extension=propro.so -d extension=raphf.so/' \
+ Makefile || die
+ SKIP_ONLINE_TESTS=yes NO_INTERACTION="yes" emake test
+ # Clean up testing links
+ rm modules/propro.so modules/raphf.so || die
+ done
+}