summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-mysqlnd_qc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-mysqlnd_qc')
-rw-r--r--dev-php/pecl-mysqlnd_qc/Manifest1
-rw-r--r--dev-php/pecl-mysqlnd_qc/metadata.xml12
-rw-r--r--dev-php/pecl-mysqlnd_qc/pecl-mysqlnd_qc-1.2.0.ebuild44
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-php/pecl-mysqlnd_qc/Manifest b/dev-php/pecl-mysqlnd_qc/Manifest
new file mode 100644
index 000000000000..378b12a5c96e
--- /dev/null
+++ b/dev-php/pecl-mysqlnd_qc/Manifest
@@ -0,0 +1 @@
+DIST mysqlnd_qc-1.2.0.tgz 147416 SHA256 08d64e917963c2404f77204bcc811adc1230361fcf389d1acde3a1a19edc2ae1 SHA512 7f04167e671f7018a72293c665f7d2b041c90a7005748ad102a2bbcbfb2331a07335f8a624ac35f1dc05066811e3a1caa1a2314c3b083a1276e36818872df8d2 WHIRLPOOL a901d072fab8061ecec7e4757680daaad51ab2ee8bd4aa9eff7caf6a26690491223d1f991d4f859375e346a04fc2df6c30491e28e5d722d5044bec3ad4521363
diff --git a/dev-php/pecl-mysqlnd_qc/metadata.xml b/dev-php/pecl-mysqlnd_qc/metadata.xml
new file mode 100644
index 000000000000..eed0321d324c
--- /dev/null
+++ b/dev-php/pecl-mysqlnd_qc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <maintainer>
+ <email>olemarkus@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="memcached">Use <pkg>dev-libs/libmemcached</pkg> as a storage handler</flag>
+ <flag name="sqlite">Use <pkg>dev-db/sqlite</pkg> as a storage handler</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-php/pecl-mysqlnd_qc/pecl-mysqlnd_qc-1.2.0.ebuild b/dev-php/pecl-mysqlnd_qc/pecl-mysqlnd_qc-1.2.0.ebuild
new file mode 100644
index 000000000000..5348e65cb851
--- /dev/null
+++ b/dev-php/pecl-mysqlnd_qc/pecl-mysqlnd_qc-1.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="mysqlnd_qc"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+# Fails to build with php5-6
+USE_PHP="php5-5 php5-4"
+
+inherit php-ext-pecl-r2 confutils flag-o-matic
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="A query cache plugin for the mysqlnd library"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="memcached sqlite"
+
+# Specifying targets due to USE flag transition
+DEPEND="
+ memcached? ( dev-libs/libmemcached )
+ sqlite? ( dev-db/sqlite:3 )
+ php_targets_php5-4? ( dev-lang/php:5.4[mysqlnd] )
+ php_targets_php5-5? ( || (
+ dev-lang/php:5.5[-libmysqlclient,mysql]
+ dev-lang/php:5.5[-libmysqlclient,mysqli]
+ )
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # configure does not find pthreads when memcache is enabled
+ use memcached && append-flags -pthread
+ enable_extension_withonly libmemcached-dir memcached 0 "${ROOT}usr"
+ enable_extension_enable mysqlnd_qc_memcache memcached
+ enable_extension_withonly sqlite-dir sqlite 0 "${ROOT}usr"
+ enable_extension_enable mysqlnd_qc_sqlite sqlite
+ php-ext-source-r2_src_configure
+}