summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-12-08 16:21:05 -0500
committerBrian Evans <grknight@gentoo.org>2020-12-08 16:40:48 -0500
commit671c6fa0d444fca275cb16dc2a4c08da65d98883 (patch)
treef73b553c75ae84da8e8db16bc7669ad844dd37bd /dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild
parentdev-php/pecl-mailparse: Drop 7-1 target; add 8-0 target (diff)
downloadgentoo-671c6fa0d444fca275cb16dc2a4c08da65d98883.tar.gz
gentoo-671c6fa0d444fca275cb16dc2a4c08da65d98883.tar.bz2
gentoo-671c6fa0d444fca275cb16dc2a4c08da65d98883.zip
dev-php/pecl-oauth: Simplify effective deps; Add 8.0 target
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild')
-rw-r--r--dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild b/dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild
index 18221a56290e..775332d83c50 100644
--- a/dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild
+++ b/dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild
@@ -6,7 +6,7 @@ PHP_EXT_NAME="oauth"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
-USE_PHP="php7-2 php7-3 php7-4"
+USE_PHP="php7-2 php7-3 php7-4 php8-0"
inherit php-ext-pecl-r3
@@ -17,12 +17,11 @@ LICENSE="BSD"
SLOT="7"
IUSE="+curl examples"
-DEPEND="php_targets_php7-2? ( dev-lang/php:7.2[hash(-)]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-3? ( dev-lang/php:7.3[hash(-)]
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
- php_targets_php7-4? (
- dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
+DEPEND="
+ dev-libs/libpcre:3=
+ curl? ( net-misc/curl:0= )
+ php_targets_php7-2? ( dev-lang/php:7.2[hash(-)] )
+ php_targets_php7-3? ( dev-lang/php:7.3[hash(-)] )
"
RDEPEND="${DEPEND}"