summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-09-30 18:31:37 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-09-30 20:03:46 +0200
commitff00d820697e94ba51f398fd9134463fa04dc45d (patch)
tree56925f599f764caa047ebcdb4d2edaffde0a0c61 /dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild
parentdev-php/PEAR-HTML_QuickForm2: bump to v2.2.0 (diff)
downloadgentoo-ff00d820697e94ba51f398fd9134463fa04dc45d.tar.gz
gentoo-ff00d820697e94ba51f398fd9134463fa04dc45d.tar.bz2
gentoo-ff00d820697e94ba51f398fd9134463fa04dc45d.zip
dev-php/pecl-oauth: bump to v2.0.7
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild')
-rw-r--r--dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild b/dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild
new file mode 100644
index 000000000000..18221a56290e
--- /dev/null
+++ b/dev-php/pecl-oauth/pecl-oauth-2.0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PHP_EXT_NAME="oauth"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php7-2 php7-3 php7-4"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="OAuth is an authorization protocol built on top of HTTP"
+LICENSE="BSD"
+SLOT="7"
+IUSE="+curl examples"
+
+DEPEND="php_targets_php7-2? ( dev-lang/php:7.2[hash(-)]
+ dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
+ php_targets_php7-3? ( dev-lang/php:7.3[hash(-)]
+ dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
+ php_targets_php7-4? (
+ dev-libs/libpcre:3= curl? ( net-misc/curl:0= ) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-oauth
+ $(use_with curl)
+ )
+ php-ext-source-r3_src_configure
+}