summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-oauth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-oauth')
-rw-r--r--dev-php/pecl-oauth/Manifest1
-rw-r--r--dev-php/pecl-oauth/metadata.xml8
-rw-r--r--dev-php/pecl-oauth/pecl-oauth-1.2.3-r2.ebuild30
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/pecl-oauth/Manifest b/dev-php/pecl-oauth/Manifest
new file mode 100644
index 000000000000..9f1fb3cf5070
--- /dev/null
+++ b/dev-php/pecl-oauth/Manifest
@@ -0,0 +1 @@
+DIST oauth-1.2.3.tgz 45531 SHA256 86bb5ee37afe672d4532ad784c7f711855c79f0dabf0acacafd5344ab6cf0195 SHA512 ca61dbec8fa51679accb31eab90b8699c7780f2d60a83566ce05667148ee44b7dc70fd8235414d6a3a996b252ad4a236b3e8a549685fd7e890e0874029c455e1 WHIRLPOOL 20969ea78c25152ac8e32d0c726bd112bdc5cb2b8d2fc59401d2c43f3d8990ed51702235afb07f0b8af604a5cf7264661caff1a8fc6bc7db25e71d682583a69c
diff --git a/dev-php/pecl-oauth/metadata.xml b/dev-php/pecl-oauth/metadata.xml
new file mode 100644
index 000000000000..928b80f50abc
--- /dev/null
+++ b/dev-php/pecl-oauth/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
+
diff --git a/dev-php/pecl-oauth/pecl-oauth-1.2.3-r2.ebuild b/dev-php/pecl-oauth/pecl-oauth-1.2.3-r2.ebuild
new file mode 100644
index 000000000000..e409572d0c69
--- /dev/null
+++ b/dev-php/pecl-oauth/pecl-oauth-1.2.3-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PHP_EXT_NAME="oauth"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="OAuth is an authorization protocol built on top of HTTP"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+for target in ${USE_PHP}; do
+ slot=${target/php}
+ slot=${slot/-/.}
+ PHPUSEDEPEND="${PHPUSEDEPEND}
+ php_targets_${target}? ( dev-lang/php:${slot}[hash] )"
+done
+
+DEPEND="${PHPUSEDEPEND}"
+RDEPEND="${DEPEND}"