summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-12-28 01:50:12 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-12-28 02:28:23 +0100
commit69850dd1cb39206d881af89b5175a3cb3f709941 (patch)
tree7e648d1883e1e98d84c4367ecf285ccc616c1b18 /dev-php/pecl-redis
parentdev-php/pecl-imagick: add php8.3 support (diff)
downloadgentoo-69850dd1cb39206d881af89b5175a3cb3f709941.tar.gz
gentoo-69850dd1cb39206d881af89b5175a3cb3f709941.tar.bz2
gentoo-69850dd1cb39206d881af89b5175a3cb3f709941.zip
dev-php/pecl-redis: add 6.0.2
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-php/pecl-redis')
-rw-r--r--dev-php/pecl-redis/Manifest1
-rw-r--r--dev-php/pecl-redis/pecl-redis-6.0.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/Manifest b/dev-php/pecl-redis/Manifest
index 44e73f46b94f..8bba19119471 100644
--- a/dev-php/pecl-redis/Manifest
+++ b/dev-php/pecl-redis/Manifest
@@ -1,2 +1,3 @@
DIST redis-5.3.6.tgz 274235 BLAKE2B 8479b3060abb99f765b27fd8937cb4c7ef92c55c0581ae6a69dd06113367547d546a9f96a8418df928f258520cb0fed6f5d39f6d88972c74b8446134be08edc4 SHA512 e5047ba9974ff6065be0fe8614aea8bf7d7c77b3a4ca08b19d0bb53069dd164614ffd19bf09bda458511abddce438fd816c28a169536388c8c4cd923596aadf0
DIST redis-5.3.7.tgz 275200 BLAKE2B 50cff3d36e189593a741ed3fe05c3558e6a0621e7ff906e4902ba39e3f7d3ae5b9bfa554480a131e32bcc0334bccbd3aa5507dc714b6d4b20ac808139c525a95 SHA512 b945d5aa86d3f58e75094369b0f324e987202f104aca7d7b46ba23cfaed54d186bb66931e200dd16d2dbeea11732dd0311da4e3d7485c3b725027f7924652832
+DIST redis-6.0.2.tgz 365966 BLAKE2B d8baebb64e1a2b8799da151253b98d045beebcbdadae7b6081f3a8e29fe20ca0928cac027ebb74264b25b900d7c04ea2e15a07b20090aa529299808878fc45d0 SHA512 1918d15433d1b4d782a9fb0364f6dfeed8d9e6c2ae70c34e235be5f890992c73a40ef19842e0aabb181da86dd2cde28b9aebab8698b387738321298a2ab94aa6
diff --git a/dev-php/pecl-redis/pecl-redis-6.0.2.ebuild b/dev-php/pecl-redis/pecl-redis-6.0.2.ebuild
new file mode 100644
index 000000000000..a503233916ff
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-6.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PHP_EXT_NAME="redis"
+USE_PHP="php8-1 php8-2 php8-3"
+PHP_EXT_NEEDED_USE="json(+)?,session(-)?"
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP extension for interfacing with Redis"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64"
+IUSE="igbinary +json lz4 +session zstd"
+
+DEPEND="
+ igbinary? ( >=dev-php/igbinary-3.0.1-r1[php_targets_php8-0(-)?,php_targets_php8-1(-)?,php_targets_php8-2(-)?] )
+ lz4? ( app-arch/lz4:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}
+ !dev-php/pecl-redis:7"
+
+# The test suite requires network access.
+RESTRICT=test
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-redis
+ --disable-redis-lzf
+ --disable-redis-msgpack
+ $(use_enable igbinary redis-igbinary)
+ $(use_enable json redis-json)
+ $(use_enable lz4 redis-lz4)
+ $(use_with lz4 liblz4)
+ $(use_enable session redis-session)
+ $(use_enable zstd redis-zstd)
+ $(use_with zstd libzstd)
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_test() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ # Run tests for Redis class
+ ${PHPCLI} -d extension=modules/redis.so \
+ tests/TestRedis.php \
+ --class Redis \
+ --host ${PECL_REDIS_HOST} || die 'test suite failed'
+ done
+}