summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2015-09-26 21:50:17 -0400
committerMichael Orlitzky <mjo@gentoo.org>2015-12-08 16:37:57 -0500
commite286291b9c1c4285f34634273d35ff381e09a1ed (patch)
tree76bd7bea098289a03fe2d30e45df773bb74aa9ab /dev-php/pecl-redis
parentsys-boot/grub:0 - Force -O0 to work around bugs 564890, 566638 (diff)
downloadgentoo-e286291b9c1c4285f34634273d35ff381e09a1ed.tar.gz
gentoo-e286291b9c1c4285f34634273d35ff381e09a1ed.tar.bz2
gentoo-e286291b9c1c4285f34634273d35ff381e09a1ed.zip
dev-php/pecl-redis: revision bump to fix incorrect DOCS.
Update the DOCS array to contain accurate filenames. Due to a bug in php-ext-source-r2.eclass, it currently is not an error when DOCS contains bad values. Before that can change, we need to fix the existing ebuilds. As part of the revbump, a few other cosmetic issues were fixed. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-php/pecl-redis')
-rw-r--r--dev-php/pecl-redis/pecl-redis-2.2.7-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-php/pecl-redis/pecl-redis-2.2.7-r1.ebuild b/dev-php/pecl-redis/pecl-redis-2.2.7-r1.ebuild
new file mode 100644
index 000000000000..276b547335b9
--- /dev/null
+++ b/dev-php/pecl-redis/pecl-redis-2.2.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PHP_EXT_NAME="redis"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-4 php5-5 php5-6"
+
+DOCS="arrays.markdown README.markdown"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="PHP extension for interfacing with Redis"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="igbinary"
+
+DEPEND="igbinary? (
+ php_targets_php5-4? ( dev-php/igbinary[php_targets_php5-4] )
+ php_targets_php5-5? ( dev-php/igbinary[php_targets_php5-5] )
+ php_targets_php5-6? ( dev-php/igbinary[php_targets_php5-6] ) )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ my_conf="--enable-redis
+ $(use_enable igbinary redis-igbinary)"
+
+ php-ext-source-r2_src_configure
+}