summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-05-12 09:48:04 -0400
committerBrian Evans <grknight@gentoo.org>2017-05-12 09:48:04 -0400
commitb8b3c3782404e9cb37fbd002ac560f2734c7317d (patch)
treeb5aa4bde23301cba23cc246697f81c6619a11d69 /dev-php/pecl-stomp/pecl-stomp-2.0.1.ebuild
parentdev-python/pycountry: Add python3_6 (diff)
downloadgentoo-b8b3c3782404e9cb37fbd002ac560f2734c7317d.tar.gz
gentoo-b8b3c3782404e9cb37fbd002ac560f2734c7317d.tar.bz2
gentoo-b8b3c3782404e9cb37fbd002ac560f2734c7317d.zip
dev-php/pecl-stomp: Version bump including php 7.1 support
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-php/pecl-stomp/pecl-stomp-2.0.1.ebuild')
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.1.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.1.ebuild
new file mode 100644
index 000000000000..a5a0477007f3
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-2.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6 php7-0 php7-1"
+PHP_EXT_NAME="stomp"
+DOCS=( CREDITS doc/classes.php doc/functions.php )
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php7-0 php7-1"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension to communicate with Stomp message brokers"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE="examples ssl test"
+
+DEPEND="${DEPEND}
+ php_targets_php7-0? ( dev-lang/php:7.0[ssl?] )
+ php_targets_php7-1? ( dev-lang/php:7.1[ssl?] )
+"
+
+RDEPEND="${DEPEND}
+ php_targets_php5-6? ( dev-php/pecl-stomp:0 )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-stomp
+ --with-openssl-dir=$(usex ssl "${EPREFIX}/usr")
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}