summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-xdiff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-xdiff')
-rw-r--r--dev-php/pecl-xdiff/Manifest1
-rw-r--r--dev-php/pecl-xdiff/metadata.xml5
-rw-r--r--dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r2.ebuild25
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/pecl-xdiff/Manifest b/dev-php/pecl-xdiff/Manifest
new file mode 100644
index 000000000000..b5050467cba1
--- /dev/null
+++ b/dev-php/pecl-xdiff/Manifest
@@ -0,0 +1 @@
+DIST xdiff-1.5.2.tgz 9275 SHA256 ebe72b887fcd2296f1e4032d476a8a463803ccfb0b34b403be8433daf3cfd81d SHA512 738d9624155b6d77b01fdef59eb0d34de6b4a8f757d2c0ccb6dd0140d021b6c88388312d6a43197dc5c24f8e643069c3a265fc0d17246e25e8104b00facf2dd0 WHIRLPOOL ee283ba7debacda6b46c931923469d98daae599b5e7a103eebeaea6044bcea3ee6f0bcd3f060463198724d62543a81ee55e570aa1584714a97a94cbd44dc8d6e
diff --git a/dev-php/pecl-xdiff/metadata.xml b/dev-php/pecl-xdiff/metadata.xml
new file mode 100644
index 000000000000..0575d3a570dc
--- /dev/null
+++ b/dev-php/pecl-xdiff/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r2.ebuild b/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r2.ebuild
new file mode 100644
index 000000000000..90133ccca0ff
--- /dev/null
+++ b/dev-php/pecl-xdiff/pecl-xdiff-1.5.2-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PHP_EXT_NAME="xdiff"
+PHP_EXT_PECL_PKG="xdiff"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README.API"
+
+USE_PHP="php5-6 php5-4 php5-5"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~x86 ~amd64"
+
+DESCRIPTION="PHP extension for generating diff files"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/libxdiff"
+RDEPEND="${DEPEND}"