summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-12-18 09:30:22 -0500
committerBrian Evans <grknight@gentoo.org>2018-12-18 10:34:41 -0500
commite46e9c2814d5592f1744e514143695274fc3a24f (patch)
treea7519907015a21050cb08b2c8c10b8be6b103f9c /dev-php/pecl-yaml/pecl-yaml-1.3.2.ebuild
parentdev-php/pecl-yaml: Version bump for 2.0.4 (diff)
downloadgentoo-e46e9c2814d5592f1744e514143695274fc3a24f.tar.gz
gentoo-e46e9c2814d5592f1744e514143695274fc3a24f.tar.bz2
gentoo-e46e9c2814d5592f1744e514143695274fc3a24f.zip
dev-php/pecl-yaml: Version bump for 1.3.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-yaml/pecl-yaml-1.3.2.ebuild')
-rw-r--r--dev-php/pecl-yaml/pecl-yaml-1.3.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-php/pecl-yaml/pecl-yaml-1.3.2.ebuild b/dev-php/pecl-yaml/pecl-yaml-1.3.2.ebuild
new file mode 100644
index 000000000000..5d179e7121f2
--- /dev/null
+++ b/dev-php/pecl-yaml/pecl-yaml-1.3.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV="${PV/_beta/b}"
+PHP_EXT_PECL_FILENAME="yaml-${MY_PV}.tgz"
+PHP_EXT_NAME="yaml"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( CREDITS README )
+
+USE_PHP="php7-0 php7-1 php7-2 php7-3 php5-6"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+S="${WORKDIR}/yaml-${MY_PV}"
+PHP_EXT_S="${S}"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="YAML 1.1 (YAML Ain't Markup Language) serialization for PHP"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/libyaml-0.1.0"
+RDEPEND="${DEPEND}"
+PDEPEND="
+ php_targets_php7-0? ( dev-php/pecl-yaml:7[php_targets_php7-0] )
+ php_targets_php7-1? ( dev-php/pecl-yaml:7[php_targets_php7-1] )
+ php_targets_php7-2? ( dev-php/pecl-yaml:7[php_targets_php7-2] )
+ php_targets_php7-3? ( dev-php/pecl-yaml:7[php_targets_php7-3] )
+"
+PHP_EXT_ECONF_ARGS=""
+
+src_prepare() {
+ if use php_targets_php5-6 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php5-6 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}