summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-08-14 10:11:35 -0400
committerBrian Evans <grknight@gentoo.org>2017-08-14 11:00:53 -0400
commitc60297951cb04a193f920a401d107cdc976794e1 (patch)
tree98b3e6e115916bc4ecc4ec28b77f0e5196acda57 /dev-php/pecl-yaml/pecl-yaml-2.0.2.ebuild
parentdev-php/pecl-redis: Version bump wrt bug 627818 (diff)
downloadgentoo-c60297951cb04a193f920a401d107cdc976794e1.tar.gz
gentoo-c60297951cb04a193f920a401d107cdc976794e1.tar.bz2
gentoo-c60297951cb04a193f920a401d107cdc976794e1.zip
dev-php/pecl-yaml: Version bump for 2.0.2
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-php/pecl-yaml/pecl-yaml-2.0.2.ebuild')
-rw-r--r--dev-php/pecl-yaml/pecl-yaml-2.0.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-php/pecl-yaml/pecl-yaml-2.0.2.ebuild b/dev-php/pecl-yaml/pecl-yaml-2.0.2.ebuild
new file mode 100644
index 000000000000..bcd73c631481
--- /dev/null
+++ b/dev-php/pecl-yaml/pecl-yaml-2.0.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV="${PV/_rc/RC}"
+PHP_EXT_PECL_FILENAME="yaml-${MY_PV}.tgz"
+PHP_EXT_NAME="yaml"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( CREDITS README )
+
+USE_PHP="php7-0 php7-1 php7-2 php5-6"
+
+inherit php-ext-pecl-r3
+
+S="${WORKDIR}/yaml-${MY_PV}"
+PHP_EXT_S="${S}"
+USE_PHP="php7-0 php7-1 php7-2"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="YAML 1.1 (YAML Ain't Markup Language) serialization for PHP"
+LICENSE="MIT"
+SLOT="7"
+IUSE=""
+
+DEPEND=">=dev-libs/libyaml-0.1.0"
+RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-yaml:0[php_targets_php5-6] )"
+PHP_EXT_ECONF_ARGS=""
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}