summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-04-05 11:04:19 -0400
committerBrian Evans <grknight@gentoo.org>2018-04-06 09:47:50 -0400
commit63da9745ea99790914f34b321b064db64cd3cd5f (patch)
tree761e65b392799667d6c4acfae4b19ebd9ffd2eec /dev-php/pecl-yaz/pecl-yaz-1.2.2-r1.ebuild
parentdev-libs/libressl: remove vulnerable versions, bug #652676 (diff)
downloadgentoo-63da9745ea99790914f34b321b064db64cd3cd5f.tar.gz
gentoo-63da9745ea99790914f34b321b064db64cd3cd5f.tar.bz2
gentoo-63da9745ea99790914f34b321b064db64cd3cd5f.zip
dev-php/pecl-yaz: Revbump for php 7.2 support
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-php/pecl-yaz/pecl-yaz-1.2.2-r1.ebuild')
-rw-r--r--dev-php/pecl-yaz/pecl-yaz-1.2.2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-php/pecl-yaz/pecl-yaz-1.2.2-r1.ebuild b/dev-php/pecl-yaz/pecl-yaz-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..aa7a51a8b8ad
--- /dev/null
+++ b/dev-php/pecl-yaz/pecl-yaz-1.2.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="yaz"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( README )
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="This extension implements a Z39.50 client for PHP using the YAZ toolkit"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/yaz-3.0.2:0="
+RDEPEND="${DEPEND}"
+
+PHP_EXT_ECONF_ARGS="--with-yaz=/usr"