summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-04-10 12:03:44 -0400
committerBrian Evans <grknight@gentoo.org>2018-04-10 12:03:44 -0400
commitbb52ad3c42af02c2578532d6280dcaaf424c6368 (patch)
treeba05a3436bd6b046cca5fd67b6318e5a911a8ce4 /dev-php/pecl-zmq/pecl-zmq-1.1.3-r1.ebuild
parentdev-php/pecl-ssh2: Version bump to 1.1.2; update live build (diff)
downloadgentoo-bb52ad3c42af02c2578532d6280dcaaf424c6368.tar.gz
gentoo-bb52ad3c42af02c2578532d6280dcaaf424c6368.tar.bz2
gentoo-bb52ad3c42af02c2578532d6280dcaaf424c6368.zip
dev-php/pecl-zmq: Revbump for PHP 7.2 support; update live build
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-php/pecl-zmq/pecl-zmq-1.1.3-r1.ebuild')
-rw-r--r--dev-php/pecl-zmq/pecl-zmq-1.1.3-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/pecl-zmq/pecl-zmq-1.1.3-r1.ebuild b/dev-php/pecl-zmq/pecl-zmq-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..f11a7b1e8df9
--- /dev/null
+++ b/dev-php/pecl-zmq/pecl-zmq-1.1.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP Bindings for ZeroMQ messaging"
+LICENSE="BSD"
+SLOT="0"
+IUSE="czmq"
+
+RDEPEND="net-libs/zeromq czmq? ( <net-libs/czmq-3 )"
+DEPEND="${RDEPEND} virtual/pkgconfig"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=( $(use_with czmq) )
+ php-ext-source-r3_src_configure
+}