summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-07-07 10:28:16 -0400
committerBrian Evans <grknight@gentoo.org>2017-07-07 10:39:33 -0400
commit27fe16de0780e579db056596b937f7425f7bc267 (patch)
tree3307eb6d594d29ce08746c3b2d9fe62378cb45bd /dev-php/pecl-zmq/pecl-zmq-9999.ebuild
parentdev-php/pecl-imagick: Drop old (diff)
downloadgentoo-27fe16de0780e579db056596b937f7425f7bc267.tar.gz
gentoo-27fe16de0780e579db056596b937f7425f7bc267.tar.bz2
gentoo-27fe16de0780e579db056596b937f7425f7bc267.zip
dev-php/pecl-zmq: New package wrt Bug 325351
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-php/pecl-zmq/pecl-zmq-9999.ebuild')
-rw-r--r--dev-php/pecl-zmq/pecl-zmq-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/pecl-zmq/pecl-zmq-9999.ebuild b/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
new file mode 100644
index 000000000000..9e61585d5f61
--- /dev/null
+++ b/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3 git-r3
+
+KEYWORDS=""
+
+DESCRIPTION="PHP Bindings for ZeroMQ messaging"
+LICENSE="BSD"
+SLOT="0"
+IUSE="czmq"
+
+RDEPEND="net-libs/zeromq czmq? ( <net-libs/czmq-3 )"
+DEPEND="${RDEPEND} virtual/pkgconfig"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/mkoppanen/php-zmq.git"
+EGIT_CHECKOUT_DIR="${PHP_EXT_S}"
+
+src_unpack() {
+ git-r3_src_unpack
+ php-ext-source-r3_src_unpack
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=( $(use_with czmq) )
+ php-ext-source-r3_src_configure
+}