summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2018-02-14 12:18:06 -0500
committerMichael Orlitzky <mjo@gentoo.org>2018-02-14 12:32:45 -0500
commitf9c3acec64afaf52017ecf10cb32ff064454b2b5 (patch)
tree8385a9ecb104ce5a500927cb20deec47e7bd175f /dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild
parentdev-php/phar-io-manifest: new package (diff)
downloadgentoo-f9c3acec64afaf52017ecf10cb32ff064454b2b5.tar.gz
gentoo-f9c3acec64afaf52017ecf10cb32ff064454b2b5.tar.bz2
gentoo-f9c3acec64afaf52017ecf10cb32ff064454b2b5.zip
dev-php/phar-io-manifest: minor ebuild and autoloader cleanup.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild')
-rw-r--r--dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild b/dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild
index a9bec3adf3c4..c70be9f4ebe4 100644
--- a/dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild
+++ b/dev-php/phar-io-manifest/phar-io-manifest-1.0.1.ebuild
@@ -3,26 +3,25 @@
EAPI=6
-MY_PN="manifest"
-
-DESCRIPTION="Component for reading phar.io manifest information from a PHP Archive (PHAR)"
+DESCRIPTION="Reading phar.io manifest information from a PHP Archive (PHAR)"
HOMEPAGE="https://github.com/phar-io/manifest"
-SRC_URI="https://github.com/phar-io/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE=""
+IUSE="examples"
-S="${WORKDIR}/${MY_PN}-${PV}"
+S="${WORKDIR}/manifest-${PV}"
RDEPEND="dev-php/fedora-autoloader
- >=dev-php/phar-io-version-1.0.1
- >=dev-lang/php-5.6[phar]"
+ dev-php/phar-io-version
+ dev-lang/php:*[phar]"
src_install() {
insinto /usr/share/php/PharIo/Manifest
doins -r src/*
doins "${FILESDIR}/autoload.php"
dodoc README.md
+ use examples && dodoc -r examples
}