summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:13:14 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:33:02 +0200
commita54eff9b7bbdd87428e864bb77127ffc83a2604e (patch)
treeff21f2847f999cf75f42bd17a74f1223a803357d /dev-php/phar-io-manifest
parentdev-php/PHP_CodeSniffer: bump to v3.6.1 (diff)
downloadgentoo-a54eff9b7bbdd87428e864bb77127ffc83a2604e.tar.gz
gentoo-a54eff9b7bbdd87428e864bb77127ffc83a2604e.tar.bz2
gentoo-a54eff9b7bbdd87428e864bb77127ffc83a2604e.zip
dev-php/phar-io-manifest: bump to v2.0.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/phar-io-manifest')
-rw-r--r--dev-php/phar-io-manifest/Manifest1
-rw-r--r--dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-php/phar-io-manifest/Manifest b/dev-php/phar-io-manifest/Manifest
index 3e0b56dae27b..7f3d77dc80ab 100644
--- a/dev-php/phar-io-manifest/Manifest
+++ b/dev-php/phar-io-manifest/Manifest
@@ -1,2 +1,3 @@
DIST phar-io-manifest-1.0.3.tar.gz 21903 BLAKE2B 48fb8858ea6c89415e78da399e2d3b6660e1857958094bf5e6c42465cfc32e34122ec1ab6e413f36f48e288ef40af7b85f93c80e6a2cfa547a166557de04ec97 SHA512 f8f9a6d4b761b739ec24a9f94ae5d4ac74f7276621675e3f3c7c3085aa7662c73cc703b1c86531d327199cf42074bb19446c14f78a3c8a888b1d236dc59bed94
DIST phar-io-manifest-2.0.1.tar.gz 10146 BLAKE2B dad3a04bf63c53c2cf4c715eb752ca57458f936a0872db481e81452b9efc8f10bb3903248cb834c8e25eb88987b68545903e1f68876e284597f54ceef755dfe8 SHA512 5c9772a5a48f17abab3806bbb8f9c07a2f26f3231385fb7dd7dcdc390f925f0f7de2d07d8b0bb4e966de86c3262bb4900cf81c1bf897fb38425aa8d644c74e95
+DIST phar-io-manifest-2.0.3.tar.gz 10249 BLAKE2B 3463a52fac2d0392b9c4a40089b536b0aebdbfe51154dbeab093da386085ead91eb95cdd133eb4464bde3a616b13c5a5772af2d97edfc585b0fa1128ef2a5166 SHA512 c0c646f0770e66909377f5f4b6b755ecfc070c44ac83d58c3ad07d79aa4481092e7c702e62d0ee65b036dd5de8ba45356d85717a733f141248e41f77d54bbe86
diff --git a/dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild b/dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild
new file mode 100644
index 000000000000..25f65d07e8d4
--- /dev/null
+++ b/dev-php/phar-io-manifest/phar-io-manifest-2.0.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Reading phar.io manifest information from a PHP Archive (PHAR)"
+HOMEPAGE="https://github.com/phar-io/manifest"
+SRC_URI="https://github.com/phar-io/manifest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="examples"
+
+CDEPEND="dev-php/fedora-autoloader
+ >=dev-php/phar-io-version-3.0.1
+ >=dev-lang/php-7.2:*[phar,xml(-),xmlwriter(-)]"
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/manifest-${PV}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src \
+ || die
+
+ cat >> src/autoload.php <<EOF || die "failed to extend autoload.php"
+
+// Dependencies
+\Fedora\Autoloader\Dependencies::required([
+ '/usr/share/php/PharIo/Version/autoload.php'
+]);
+EOF
+}
+
+src_install() {
+ insinto /usr/share/php/PharIo/Manifest
+ doins -r src/*
+ dodoc README.md
+ use examples && dodoc -r examples
+}