summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-05-18 20:48:01 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-05-18 20:48:01 +0200
commit84298226d18397f7e163d16018b1d6cfca28fe9f (patch)
treea3223f509a04770fa6cc7e2ff4a059f0bc2c3b88 /dev-php/phar-io-version/phar-io-version-3.1.0.ebuild
parentdev-php/PEAR-Log: bump to v1.13.3 (diff)
downloadgentoo-84298226d18397f7e163d16018b1d6cfca28fe9f.tar.gz
gentoo-84298226d18397f7e163d16018b1d6cfca28fe9f.tar.bz2
gentoo-84298226d18397f7e163d16018b1d6cfca28fe9f.zip
dev-php/phar-io-version: bump to v3.1.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/phar-io-version/phar-io-version-3.1.0.ebuild')
-rw-r--r--dev-php/phar-io-version/phar-io-version-3.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/phar-io-version/phar-io-version-3.1.0.ebuild b/dev-php/phar-io-version/phar-io-version-3.1.0.ebuild
new file mode 100644
index 000000000000..1c28ee251730
--- /dev/null
+++ b/dev-php/phar-io-version/phar-io-version-3.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Library for handling version information and constraints"
+HOMEPAGE="https://github.com/phar-io/version"
+SRC_URI="https://github.com/phar-io/version/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/version-${PV}"
+
+CDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.2:*"
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src \
+ || die
+}
+
+src_install() {
+ insinto /usr/share/php/PharIo/Version
+ doins src/*.php
+ dodoc README.md
+}